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Preliminary Notes
• This documentation applies to the first-time users of PSpice circuit simulation software. It should not be understood either as a training 

manual or as a complete operating manual.

• In order to run the software, you need a valid PSpice Designer License (PO1520), or you have received valid licenses from the OrCAD 
student program. You can also request a free trial version from the OrCAD home page.

• Basic knowledge in electronic circuitry is helpful.

• Due to brevity and compactness of this documentation, it is not possible to address all existing functions and their details. 
Please refer to Help > PSpice Documentation.

• Based on a simple circuit diagram for a power supply, most important functions and steps are presented, which will allow first-time user to 
quickly manage his own tasks with minimum training efforts spent.

• After some brief information on user interface of the software and on different simulation types, hands-on instructions begin with entering 
circuit diagram from scratch on page 30.

• To get started, just unzip pspice-demo-22-1.zip file to a folder of your choice and then start already installed OrCAD Capture software.
− Make sure, that the pathname and the name of the folder does not contain any special characters or white spaces!

• Detailed training offers for the different tools can be found at https://www.flowcad.com/en/training.htm

https://www.flowcad.com/en/student-program.htm
https://www.flowcad.com/en/student-program.htm
https://www.orcad.com/orcad-free-trial
https://www.flowcad.com/en/training.htm
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Capture / PSpice User Interface
OrCAD Capture and OrCAD PSpice are two tightly connected, but separated tools where OrCAD Capture is used to design your circuit on a 
schematic including the preparation of all the inputs required by OrCAD PSpice.

OrCAD PSpice itself is the circuit simulator coming along with a comfortable user interface for displaying the simulation results.

OrCAD Capture and OrCAD PSpice are mostly menu driven.

All Capture and PSpice commands are launched by
• Pull-down menus 
• Icon Toolbars
• Keyboard Shortcuts
• Pop-up windows
• Command windows
• Tcl functions

Basically all menus in Capture and PSpice are context-sensitive. This means that depending on which elements are selected, workspaces or 
commands, resulting pop-up windows or pull-down menus will change it’s appearance. It will show only relevant functions or objects you 
need to work on for just selected elements.

As there are restrictions which special characters in PSpice data, it is highly recommended to use only underline character ( _ ) as a special 
character in path and name of the design!
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Unit of Measurements, Value Multipliers in PSpice
PSpice only calculates with plain numbers, not with units.

PSpice recognizes these value multipliers:

1f (femto-) = 1 x 10-15

1p (pico-) = 1 x 10-12

1n (nano-) = 1 x 10-9

1u (micro-) = 1 x 10-6

1mil (mil) = 2.54 x 10-5

1m (milli-) = 1 x 10-3

1K (kilo-) = 1 x 103

1Meg (mega-) = 1 x 106

1G (giga-) = 1 x 109

1T (tera-) = 1 x 1012

Tip
• Units such as Ohm, Volt, Farad, Henry, etc. are not 

considered. They are used only for better readability of 
relevant circuit.

• If an input is made after such a measure or expression, 
PSpice interprets this as a comment.

 1KOhm = 1K

• Although Capture translates expressions like 2k2 correctly 
into 2.2k for the PSpice netlist, it is not recommended to 
use such expressions in your circuit schematics. You may 
fail with other tools and break with other conventions.

Attention
• PSpice is not case-sensitive.

1M = 1m
M or m in PSpice means both milli

• 1 x 106 = 1Meg = 1MEG = 1meg
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Proposed Circuit
• Aim of this PSpice introduction is to simulate a complete circuit, particularly a Switched Mode Power Supply (SMPS), which consists of a 

source, a rectifier, a PWM-Control, a transformer, a LP-Filter plus the load.*

• When you extract data in quickstart container, you’ll find a solution directory, which contains an example of how to simulate the overall 
circuit. You will find here a circuit using European schematic symbols. Default Cadence symbols are American ones, that is why, you will 
use an external European symbol library for R, L and C (Europe.olb).

• On following pages, you will find a brief overview of actions you can take to implement circuit diagram below from scratch.

* plus mandatory simulation ground “0”
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SMPS Circuit – American Style (Default)

American Style
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SMPS Circuit – European Style (Using Europe.olb)

European Style
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Run a PSpice Simulation
There are two ways to start a simulation in PSpice:

• Directly from OrCAD Capture (preferred way, used in this tutorial):
− Launch Capture (full installation): Start > Cadence PCB 2022 > Capture CIS 2022

                         (trial installation): Start > OrCAD Trial > Capture CIS 2022
    or double-click on the Capture icon which is on your desktop after the trial installation

− First using Capture to design the circuit and creating the simulation profile, and then starting PSpice simulation from 
Capture environment via a run-button. Required netlisting and preparation of the simulation commands is done in the background.

• Or Opening directly PSpice:
− Start > Cadence PCB 2022 > PSpice AD 2022
− However, PSpice requires netlist file <*.net> and circuit file <*.cir> of circuit to be simulated. The user has to prepare both, the netlist 

and the command file. How you can do this is far beyond the intention of this tutorial.

• Lets get started with our tutorial:
Launch Capture CIS. Start > Cadence PCB 2022 > Capture CIS 2022 or double-click
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Starting Capture Session
• When starting, Capture displays an informative Start Page 

(e.g. it shows the current tool version, support information, 
last projects you’ve been working on, …).

• Try to open an existing demo design with File > Open > 
Demo Designs.
− After inspecting a demo design, close it simply by clicking 

the      icon in the project manager.

• You can also open an already existing project with 
File > Open > Project.
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Create a New PSpice Project
• Select File > New > Project. New Project window opens. 

• In upper field under Name, please enter the name of your project, e.g. SMPS.

• In Location field, enter the folder in which your new project should be stored. 
You can browse to location by clicking the browse icon      . 
It is highly recommended to use project name again as a folder entry. As a result, 
all project data generated for this simulation project are stored in this folder, 
which considerably increases the overview.
Do not use any special character (e.g. umlauts) or white space characters for the 
location and for the name!

• Select Enable PSpice Simulation.

• Click OK. 

• A new window pops up.

• Here select Create a blank project.

• Click OK.
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Project SMPS
• You have created a new project called SMPS.opj with a design of same name smps.dsn.
• At the same time, the first page of your design was opened with the name PAGE1. Similarly, a drawing frame and a Title Block* were 

automatically placed. Other view-presets are possible.
• Please note the folder structure in project manager on the left side. Expand the items by clicking on the      icon in front of the folder.
• The folder structure is virtual. It only exists within project manager. PAGE1 located under Schematic1 is only found within smps.dsn file.
• Icons for component placement and wiring are already visible on right-hand side.

On next slides, we will explain some 
necessary steps which you can practice 
later with your newly created project.

* Your Title Block looks different, as we have chosen a 
customized template for this slide deck.
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• There are several ways, how you can place PSpice components in your design.

• In this tutorial, you will learn how to make use of:

Placing PSpice Components  

Place Part CommandUnified CIS Browser
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Unified Component Information System (CIS) Browser 
• The Unified CIS Browser is a component management 

system with pre-configured databases.

• Allows you to browse, view, search and place components. 

• No need to care for location of supplied PSpice libraries.

• Open with Place > Component…

• You can either Browse through the PSpice components, 
walking through categories and sub-categories …

• Or you can use the intuitive Search to find your components.
− Preselecting a category or sub-category will narrow down 

your search results.

• Double-clicking on a selected component will place it in the 
current schematic.
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Unified CIS Using Browse
• Select Category PSpice and Browse

Left pane: Categories browser Middle pane: Part browser Right pane: Properties browser
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Unified CIS Using Search
• Or Select PSpice (or any other subcategory) and enter a search string.
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Place Part and Automatic Reference Designator Assignment
The traditional way of placing parts is to use:

• Place > Part…

• P (Keyboard)

• Place Part icon

Note
In order to activate the Place Part Window, 
you must select a schematic page first.

In Options > Preferences, Miscellaneous Tab 
select Automatically reference placed parts 
which allows you to automatically annotate 
component references during placement.
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Library Assignment, Selecting and Placing Parts
When you are in the Place > Part mode, the Place Part Window shows up on the right.

Under Libraries, you can select one or more libraries. All parts in these libraries will be shown in the Part List 
scrollbox. In the Part entry field, you enter the part which you are looking for. This entry field acts as a simple filter. 
No wildcards are allowed here. Clicking on a line in the scroll box will fill the part field with the selected content.

Use the Add Library icon       to add Part Libraries. The default directories with PSpice symbols are:
<installation_dir>\tools\capture\library\pspice
<installation_dir>\tools\capture\library\pspice\advanls

All the libraries shown in the Libraries window are stored in the user specific capture.ini file. 
For new PSpice projects, you don’t have to add the libraries again.

Packaging shows the number of parts inside a package.

To the right of the Symbol Preview window the two icons indicate, whether a PSpice Model       and / or a PCB 
Symbol       is assigned to the selected component.

A double-click on a Part in the Part List, or Pressing Enter in the Part line will return to the schematic and lets you 
place the selected part by pressing the LMB (Left Mouse Button).

Search for Part allows searching with wildcards. Make sure, that the path is correctly entered. Pressing Add will 
add the library to the currently selected ones.
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Wiring Components, Adding Text Notes or Other Objects
You need to connect the placed components. The simplest 
method of placing a connection is using a wire between two 
pins of components. Entering the wire mode by 

• Place > Wire

• W (keyboard)

• Wire Icon

 

You can also place graphical objects or pure text notes 
(e.g. to explain your circuit) on the schematic page:

• Place > Text

• T (keyboard)

• Place Text Icon 

Even pictures or OleObjects can be placed on a schematic 
page.
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Assign Net Names (Net Alias)
• Any new wire will get a system-generated net name like 

N0001234 by default.

• Those system-generated net names can be relaced by net 
aliases on a wire.

• Within a schematic page, any wires, off-page connectors or 
hierarchical ports with the same name are connected even 
just by their name.
− You do not have to connect them by physical wires (wireless 

connection).

Use
• Place > Net Alias
• N (keyboard)
• Net Alias Icon 

Note
When you need to connect nets over several pages or even 
design hierarchies, you must make use of off-page connectors 
and hierarchical ports. 
Please check with the tool documentation for details.

BusJunction Dot 

Net Alias
Wireless Connection

Unconnected 
part pin
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Tips for a Successful Simulation
To run a simulation of a circuit created with Capture, follow these general recommendations:
1. All components must have PSpice models attached. When placing components using the Place Part method, make sure that you are 

using components sourced from the default PSpice Library at:

<install_directory>\tools\capture\library\pspice  or
<install_directory>\tools\capture\library\pspice\advanls

The default path with Capture points to <install_directory>\tools\capture\library and will use libraries without a PSpice 
model attached!

2. PSpice needs a reference potential called “0” to run the simulation. Usually you place a global net symbol “0”          from the capsym 
library and connect it to the reference net(s). 
Use e.g. Place > PSpice Part… > PSpice Ground to get such a symbol.

3. Start with smaller circuits, rather than large ones. Divide larger circuits into smaller subcircuits.

4. Think before blindly accepting a simulation result. Apply Rule #9* before you run a simulation.

* Source: Signal Integrity Journal

https://www.signalintegrityjournal.com/blogs/4-eric-bogatin-signal-integrity-journal-technical-editor/post/1539-bogatins-20-rules-for-engineers
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Types of Simulation in PSpice
First you must setup a simulation profile before you can run a PSpice simulation. 
Here the type of the simulation and all of its input parameters are set. PSpice supports 
4 basic types of a circuit simulation:

• Bias Point (or DC) Analysis
− Static analysis, analyzing the operating and equilibrium point

• DC Sweep
− Multiple DC Analysis with one variable parameter

• Transient (time domain) Analysis
− Analyze the response of the circuit as a function of time

• AC Sweep
− Frequency-domain analysis resulting in amplitude and phase of currents 

and voltages

Create a new simulation profile

Selecting the simulation type
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Bias Point, DC Analysis
The Bias Point analysis finds an operating point of the circuit 
which are assumed to be equilibrium points – solutions which 
do not vary over time (static). 

• Static voltage, current or power values can be displayed with 
PSpice > Bias Points > Enable or using the icons in the 
toolbar: 

• Variants of the DC Analysis
− DC Sensitivity Analysis
− Transfer function (DC gain) analysis

Example
• See the example bias_point in folder 

Solution\Samples\bias_point\bias_point.opj
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DC Sweep Analysis
The DC Sweep analysis allows you to vary (sweep) a source 
(voltage or current), a global parameter, a model parameter or 
the temperature through a range of values. For each sweep 
value, the bias point is calculated.

• The results are put into the simulation output file (.out) or 
can be graphically displayed in Probe.

Example
• See the project DC_Sweep.opj in the folder 

Solution\Samples\DC_Sweep
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Time Domain (Transient) Analysis
The transient analysis computes the response of a circuit as a function of time. 
PSpice will display the results in probe. 

For the transient analysis, the simulator needs to solve nonlinear differential 
equations in the time domain. The results will be node voltages and currents 
over time. Visualizing the results in Probe is like working with an oscilloscope.

Example
• Project time_domain.opl in the folder Solution\Samples\time_domain
• The circuit will demonstrate how a capacitor is charged and discharged 

through a resistor by a periodic pulse source.

Tip
• You can change the color settings of the simulation output window in

Tools > Options. Select the Color Settings tab.

Probe result: Charge Current (red), Capacitor Voltage (green)
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AC Sweep Analysis
PSpice calculates the small-signal sinusoidal steady state response of the linearized circuit 
around the DC operating point. The AC Analysis is a frequency domain simulation.

The results are voltages and currents which can be represented with two numbers: 
the magnitude and the phase.

All sources in the circuit will operate with sinusoids at the same frequency as the input signal.

Example
• Project AC_Sweep.opj in the directory Solution\Samples\AC_Sweep

The magnitude of the capacitor voltage over the frequency
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More Simulation Options
In PSpice you can run further simulations options, which are related to the basic simulation types presented so far:

• Fourier-Analysis as part of the transient analysis.

• Temperature sweep: See the effects of your circuit depending upon the temperature.

• Worst Case and Monte Carlo Analysis: Simulate the effects of tolerances and predict the yield.

• Sensitivity Analysis: Find out, which component values will have a large effect on the output value. Optimize cost and increase quality of 
your design.

• Parametric Sweep: Modify parameters of the circuit and visualize their effects.

• Noise Analysis: as part of the AC Sweep analysis.

• Digital Simulations: Analyze digital circuits in an event driven simulation.

In this quickstart we will make use of the Parametric Sweep and the Fourier-Analysis.
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Goals
• You will design the SMPS circuit shown earlier. In this design, a 230 V / 50 Hz source will be converted into a 5 V DC output. 

• In this circuit, no PWM controller IC is used. Instead a constant 333 kHz voltage pulse with a 20 % duty cycle will be used to control the 
MOSFET.

• You will define different simulation profiles and analyze the results in the probe window using markers and additional measurements.

Note 1
The complete circuit can be found in the folder Solution\Demo_Proposed_Circuit.

Note 2
You will achieve the best learning and understanding how to use the software, when you follow the all the steps in this quickstart.
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SMPS Design (I)
• You created the SMPS project already earlier in this guide. If not, then please find the necessary steps on the pages 13 and 14.

• If not already open, open the PAGE1 of the project SMPS in Capture.

• Recap the slides on how to find components, how to perform wiring and how to change values of various components.

• Ensure, that the component values are matching with the ones shown in the circuit diagram.

• There are extra slides, how to create the coupling device K1 and how to setup the parameters.

• When you will use the traditional way of placing components (Place Part), you will need components from the libraries: 
Infineon.olb, irf.olb, magnetic.olb, PWRMOS.olb, source.olb and special.olb.

• When you want to use the European Style components, you will need to configure the Europe.olb, shipped with this tutorial, and then 
place them using the Place Part command. You can use the analog.olb if you want to use American schematic symbols. 

• There will be some additional hints, on how to design the circuit.
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Schematic of the SMPS Design (European Style)
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Design the Rectifier and Source
• Select Place > Component… and enter 40EPS08 in the Search field. Double-click on the component shown:

• Rotate the diode (R) and place 4 instances of it. Press ESC to leave the placement mode.
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Use the Modeling Application to Place the Sine Source
• Use Place > PSpice Part… > Modeling Application…

or click on this icon in the PSpice toolbar
• Select Independent Sources
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Define the Sine Source and Place it
• Select as shown and enter {Source} in the VAMPL 

parameter, and 50 as the Frequency. Then click Place.
• Rotate the source once and place it.
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Place Parts From the Europe.olb
• We use the Place Part command for all parts, which are not 

shipped with PSpice.

• In the active Schematic press P.

• In the Library section of the Place Part Window, click the 
Add Library icon

and browse to the 
PSpice_Demo_22_1\Solution\EU_Library\Europe.olb 
on your disk and click Open.

• You will now find three components in the Part List from 
which you can choose from:

• Double-click RES_AD
and place it on page1.

• Double-click the RES_AD 
text and change the value
to 0.01.
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Finalize the Rectifier and Source Part of the Schematic
• Applying the same method, place the Capacitor C1 and 

change the value to 1.2 m.

• Select Place > PSpice Part… > PSpice Ground and place 
a “0” Symbol.

• Press W to enter the Wiring Mode.

• Draw all the required connections:
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• You should now be able to finalize the rest of the schematic 
by applying the methods shown before (excl. K1 and 
PARAMETER).

• Hint: The Source driving the MOSFET is an independent 
Voltage Pulse.

Finalize the Rest of the Schematic
• The Time Period Parameter does currently not accept an 

expression value. As a workaround, leave the fix value and 
replace the parameter on the schematic by double-clicking 
on the fixed value and entering the correct {period} 
expression for the value:

• The PARAMETER and the K1 symbols will be placed next.
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Add the Global Parameters
• Place the inductors with the correct orientation 

(see the dots).

• Adapt all values according to the design.
Note: Global Parameters values are defined
between curly braces { }.

• Don’t forget to label the nets OUT and FB.

• Put the grounds into the right locations.

• In Unified CIS search for the component PARAM 
and place it on a free space in your schematic.

• Double-click on the PARAMETERS component.
The Property Editor will open:

• For your curiosity: Check what Pivot does.

• Click on New Property.

• Enter the Name D and the Value 0.2, check the Display 
(ON / OFF) and hit Apply.

• Select Name and Value and click OK.

• Repeat the steps for LOAD (50), period (3u), Source (230).

• Close the Property Editor.
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Build the Transformer
We build a nonlinear transformer based on the Jiles Atherton simulation model.

• In Unified CIS search for the core E13_6_6_3C81.

• Double-click on the only part returned from the search and place it on the 
schematic. A good place would be above the coils L1 and L2, but the location 
does not matter.

• Double-click on the placed part in the schematic 
(Tip: Double-click on the K).

• Tell the core model, that you will couple the inductors L1 and L2.

Note
The values of the inductors L1 and L2 refer to 
number of turns in conjunction with the simulation 
model used for the transformer.

• Close the Property Editor.
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Build the Simulation Profile
The circuit is complete now and should look like the reference.

Next step is to setup a simulation profile for a transient simulation.

• Click on PSpice > New Simulation Profile
or click the icon

• Name it transient and click Create.

Note

• You can create more than one simulation profile for the active schematic.

• Modifying an active profile is done with PSpice > Edit > Simulation profile
or use the icon
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Add the Simulation Details
The Simulation Settings window pops up.

• Make sure to select the Time Domain (Transient) as Analysis. The 
General Settings Option should be pre-selected. You enter the Run 
to Time as 180 ms and the Maximum Step Size to 1 ms.

• On the left side, click on Probe Window.
Select during Simulation and All Markers on open schematics 
as display options for Probe.

• Press OK to close the simulation profile.

Note
• When the Maximum Step size field is left blank, a default value of 

2 % of the Run to Time is used. The resulting curve displayed in 
Probe may be not accurate enough.

• Entering a too small value will increase the simulation time and the 
data generated.

• A reasonable value is about 1/1000 of the Run to Time.
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Run the Simulation
• Place voltage markers (PSpice > Markers > Voltage Level) or use the icon       

as shown in the picture on the bottom (the colors occur, when the simulation starts).

• Press F11, or click       to start the simulation.

• When the circuit was entered correctly, you will see that the Probe window will open 
and the waveforms for the node voltages will show-up whilst the simulation is running.

• Ignore the large data file warning you may receive 
at the end of the simulation (which takes app. 2 min 
depending on the CPU type).

Note

• Place V markers on the net, I markers on the component pin and W markers 
on the component.
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Simulation Results: Rectified Voltage
• You added already 3 voltage markers:

Blue: the rectified voltage
Red / Green: the voltage at the AC source

• Evaluation:
− The reservoir capacitor C1 flattens the rectified wave.

The large value of the capacitor has a sufficient effect,
 that the resulting waveform is already quite flat.

Note
• You can add or delete more voltage markers after the simulation 

and see the immediate effect on the probe window.

• In Probe you can also use Trace > Add Trace to display desired traces.

• The color assignment of the traces is done according to a predefined 
sequence in the pspice.ini file. You may see different colors at your end.
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Current Voltage Behavior at C1
Looking at the U-I curves at C1, you see every 10 ms (100 Hz) charging current spikes and a high frequency discharging current. The 
relatively flat voltage depends on the high capacity value of the capacitor.

• Delete the previous traces of the AC source by removing in our case the red and green voltage markers in the schematic.

• In Probe, select Plot > Add Y Axis.

• Trace > Add Trace, or click  
Then click on I(C1).

Note
• If the current I(C1) is negative in your case

then your Capacitor C1 is rotated by 180°.
PSpice measures the positive current from
pin1 to pin 2. When you rotate C1, the
sign of the current is negated.
This is not an error.
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Generation of HF Signals
The MOSFET is turned on and off by the generated voltage pulse of approximately 330 kHz, causing a HF DC current through L1, inducing a 
HF AC voltage in L2 of the transformer. 
The currents on the secondary side of the circuit are now isolated and converted to DC using the diodes D5 and D6 (green and red). 
Both currents are combined again entering L3 (blue curve).
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The Low Pass (LP) Filter
The current through the Diodes contain HF components. The LP filter should eliminate those components. To verify this, we will compare in 
two separate plot windows the current through, e.g. D6 and through the load resistor R4.

• Close Probe and delete all Markers in the schematic.

• Press F12, or Select PSpice > View Simulation Results
Probe will open again with no plot visible.

• Put an Current Marker at the Anode of D6.

• In Probe Plot > Add plot to Window.

• Add a Current Marker at Pin 1 of R4.
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The Fast Fourier Transformation (FFT)
• Press the FFT button in the top tool bar:

• Only a DC component
in the current through
the Load is left (top plot).

• You will see many
HF components
in the Diode current
(bottom plot).
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Output Voltage
• Delete all the current markers in the schematic.

• In Probe: Plot > Delete Plot.

• Place a voltage marker
on the OUT wire.

The DC voltage rises 
oscillating until it is stabilized
to a value of approx. 5 V
(transient response).
The smoothness is achieved
by the capacitor C1 and the
low pass filter.
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SMPS Parametric Sweep

https://www.flowcad.com/en/solutions.htm
https://www.flowcad.com/en/download.htm
https://www.flowcad.com/en/training.htm
https://www.flowcad.com/en/events.htm
https://www.flowcad.com/en/news.htm
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Parametric Sweep, Step 1 of 4
The Parametric Sweep allows to vary (sweep) a source (voltage or 
current), a global parameter, a model parameter or the temperature 
through a range of values. E.g., you can simulate a circuit with different 
component values and display the results with a single call.

You already prepared the design for a parametric sweep, but lets recall 
the 4 required steps to vary a global parameter (as one example):

• Step 1: Define the global parameter 
− Place the PARAM symbol somewhere on the schematic.
− It serves as a placeholder for the global parameters and defines 

default values.

a) Place Part method

b) Search in Unified CIS

Special.olb must be configured

Finding the PARAM Symbol, 
either use….
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Parametric Sweep, Step 2 of 4
• Step 2: Substitute the fixed device value with a 

parameter value 
− Double-click on the value of the device.
− Substitute the device value by the defined parameter 

name and enclose it in curly braces { } and click OK.
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Parametric Sweep, Step 3 of 4
• Step 3: Assign and display the global parameters in 

the schematic
− Double-click on the PARAMETERS schematic symbol 

to open the Property Editor.
• Click New Property.
• Type in the name and the default value of the new 

property.
• Click Apply (for more parameters to edit), or OK for 

the last parameter.
• On the Display Properties select Name and Value.
• Confirm with OK.
• Continue with all required parameters.

− Close the Property Editor.

Now the parameters are defined and visible in the schematic.



55FlowCAD Confidential  │

FlowCAD

Parametric Sweep, Step 4 of 4
• Step 4: Set up a simulation profile with Parametric Sweep 

enabled
− Edit an existing simulation profile PSpice > Edit Simulation 

Profile or click the        icon.
• Set the required simulation type: here Time Domain
− Optional: In the General Settings, remove the value of 

1m for the Maximum Step Size (to reduce the amount of 
data generated).

• Select the Parametric Sweep.
• Set the sweep Variable to Global Parameter.
• Set the Parameter Name to LOAD.
• Define the sweep values: here select Value List.
• Enter the values 10, 50 and 100 separated by spaces.
• Click OK.

− Start the simulation with F11 or 
− Choose ALL and OK in the Available Sections window which 

occurs after the simulation.
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Parametric Sweep Results (I)
You selected to show all sweep results, hence you will see 3 different traces in Probe.

Conclusion
A change in the load value will change the transient response of the output voltage.

Notes
Click RMB > Trace Information on a
single trace displays simulation details
(like the step parameter).

Plot > Transient opens the section
selection window again.

Trace > Cursor > Display or clicking
opens the Probe Cursor.

Use the icons                                           or
the Trace > Cursor submenu to perform
specific queries on individual curves.
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Parametric Sweep Results (II)
• You can use 2 cursors at the same time. Placing them on different traces allows to make measurements on the same or between two 

traces and displaying various values on the x and y axis.

• Use the cursor 1 with the LMB (Left Mouse Button) and cursor 2 with the RMB to measure e.g. the time difference between to peaks of 
one of the traces.

• First select with LMB and RMB which trace you want to measure, e.g. the red one.
You could select here also different traces with the LMB or RMB.

Max values: 7.5985 V and 5.386 V
Time difference: 54.8 ms

• You can change cursor styles with
Tools > Options > Cursor Settings.
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Parametric Sweep Results (Measurements)
You can also take measurements on plotted traces in order to evaluate characteristics of a trace:

• Click on View > Measurement Results or click       . 
This will dock this window below the simulation results.

• Click on Click here to evaluate a new measurement…
and add, e.g., max(v(out)) as trace expression.

You can also build the Trace by clicking Max(1) in the left part, 
and then select V(out) in the right part of the window.

• Click OK. You will get the measurement result for each trace:
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Conclusion
• After performing the examples in this quickstart guide, you are now able to perform first simulations with PSpice.

• This guide is only intended to demonstrate the most important steps necessary to run simulations with PSpice.

• The quickstart guide is not meant to replace any PSpice training as delivered by FlowCAD or Cadence. It does not replace carefully 
studying the extensive documentation shipped with the software.

• If PSpice models can not be found in the standard library, you can always ask the manufacturer directly. PSpice allows to add models in 
the Simulation Settings of the simulation profile in the Configuration Files tab. In addition, PSpice offers a powerful Model Editor which 
allows to create own models just based on data sheets.

• PSpice allows to simulate also mechanical or thermal elements, e.g. a shock absorber of an vehicle or the temperature distribution on a 
PCB. You only need the electrical replacement models for these types of simulation. Those are not part of the standard libraries shipped 
by Cadence.

• PSpice can handle digital and analogue signals coexisting in the same circuit by running a digital (event driven) and analogue simulation 
at the same time in one simulation.

• Using the Smoke analysis, PSpice can check if your components are used below their maximum operating conditions. PSpice identifies 
components which are stressed and improves the reliability of your circuit.
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PSpice Extensions
• Using the PSpice Advanced Analysis Option will allow you to extend the basic analogue / digital simulation features into a tool which 

helps you to improve performance, productivity, predictability, cost and the quality of your circuits, by using features like Sensitivity 
Analysis, Parametric Plots, extended Monte Carlo Analysis and the Optimizer.

• PSpice provides a system-level simulation solution, thanks to the possibility to abstract the functionality of models like microcontroller, 
state-machines, etc. using C/C++, SystemC and Verilog-A programming languages. This would allow to evaluate the whole system with 
its algorithms in only one simulator platform.

• Another possibility to extend PSpice’s application area is to link PSpice and MATLAB / Simulink. For this, Cadence offers an interface 
(SLPS) (Simulink-PSpice), which enables a co-simulation with MATLAB. You can also send simulation data to MATLAB for post-
processing and use MATLAB functions in the PSpice environment.
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Appendix

https://www.flowcad.com/en/solutions.htm
https://www.flowcad.com/en/download.htm
https://www.flowcad.com/en/training.htm
https://www.flowcad.com/en/events.htm
https://www.flowcad.com/en/news.htm
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System Requirements
Operating System Windows 11 Professional and Enterprise;

Windows 10 (64-bit) Professional and Enterprise, including Dark Theme mode
Windows Server 2016 (All Service Packs)
Windows Server 2019

Recommended Hardware Intel Core™ i7 4.30 GHz or AMD Ryzen™ 7 4.30 GHz with at least 4 cores
16 GB RAM
50 GB free disk space (SSD recommended)
1920 x 1200 display resolution with true color (at least 32-bit color)
A dedicated graphics card supporting OpenGL, min 2 GB (with additional support for DX11 for 3D canvas)
Broadband Internet connection for some services

In General Above mentioned hardware specifications are to be understood as a minimum requirement. 
Depending on the task at hand, hardware must be adapted accordingly “upwards”.
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Installation
• To run this tutorial successfully, it is expected, that the software is installed correctly on your machine and you have access to your 

PSpice license.

• Or you have installed and activated the OrCAD Trial Version 22.1.

• An installation guide of the software can be found at https://www.flowcad.com/en/download.htm.

• This tutorial is based on the SPB 22.1 release of the software.
− It will run with earlier versions of the software, but you may observe differences in some screenshots.

https://www.flowcad.com/en/download.htm
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Please do not hesitate to contact us.
Für weitere Fragen und Informationen stehen wir gerne zur Verfügung.

FlowCAD Deutschland
Mozartstr. 2
85622 Feldkirchen bei München
T +49 89 45637-770
info@FlowCAD.de

FlowCAD Schweiz
Hintermättlistr. 1
5506 Mägenwil
T +41 56 485 91 91
info@FlowCAD.ch

FlowCAD Polska
ul. Sąsiedzka 2A
80-298 Gdańsk
T +48 58 727 90 90
info@FlowCAD.pl 

Contact us / Kontakt zu FlowCAD 
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Follow Us

Don’t forget to subscribe, share and like! 

» FlowCAD.com » youtube.com/
FlowCAD

» FlowCAD.com/
newsletter

» linkedin.com/
FlowCAD

» facebook.com/
FlowCAD

» twitter.com/
FlowCAD

» instagram.com/
FlowCAD

» xing.com/
FlowCAD

http://www.twitter.com/FlowCAD
http://www.youtube.com/FlowCAD
http://www.facebook.com/FlowCAD
https://www.xing.com/companies/flowcadeda-softwarevertriebsgmbh
https://www.flowcad.com/
https://news.flowcad.ch/?p=subscribe&id=3
https://www.linkedin.com/company/flowcad/
https://www.instagram.com/flowcad.eda/
https://www.flowcad.com/de/index.htm
http://www.youtube.com/FlowCAD
http://www.youtube.com/FlowCAD
https://news.flowcad.ch/?p=subscribe&id=3
https://news.flowcad.ch/?p=subscribe&id=3
https://www.linkedin.com/company/flowcad/
https://www.linkedin.com/company/flowcad/
http://www.facebook.com/FlowCAD
http://www.facebook.com/FlowCAD
http://www.twitter.com/FlowCAD
http://www.twitter.com/FlowCAD
https://www.instagram.com/flowcad.eda/
https://www.instagram.com/flowcad.eda/
https://www.xing.com/companies/flowcadeda-softwarevertriebsgmbh
https://www.xing.com/companies/flowcadeda-softwarevertriebsgmbh
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