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Introduction – In General
• This documentation is created for first time users of OrCAD Capture Software. It is neither a training 

handbook nor a complete user manual.

• Because of the compactness of this documentation, it is not possible to take up all available 
commands and their options. Please refer to the extensive documentation within the installation, 
which is available as HTML as well as PDF.

• Based on a simple schematic, we will describe most important steps of design flow. With minimum 
effort of training it will enable first time users to manage their first tasks by them self. 

• After some preliminary information related to the software, the instructions including the circuit 
template will start on page 6.

• All commands and functions used in this tutorial are available and licensed with the trail version.

• Detailed training offers for the different tools can be found at https://www.flowcad.com/en/training.htm

https://www.flowcad.com/en/training.htm


4FlowCAD Confidential  │

Introduction – Color Scheme
• Capture CIS as well as Schematic Canvas can be operated in both, a light and a dark theme.

• Icons will appear differently depending on which theme is selected.

• The color scheme can be switched under Options > Preferences > Colors / Print.
• This quick start shows light theme.

• Light Theme

• Dark Theme
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OrCAD PCB Design Flow

• As you can see, OrCAD PCB Designer Flow mainly consists of two parts. 
− These are the schematic entry module Capture CIS and the layout module OrCAD PCB Editor. 

• Both modules are supplemented by additional sub packages who represent an ideal tool in each 
combination, enabling the user to complete all tasks with maximized efficiency.
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Schematic PCB Layout Manufacturing output
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Gerber &
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Footprint
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Schematic Template
Here you can see circuit to be implemented in this quick start:
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Schematic Template – Parts List
The circuit in this quick start contains following parts:

REFERENCE VALUE PART_NUMBER PCB Footprint

C1 220u FC-CAP-0057 capp_taj_e

C2 220u FC-CAP-0057 capp_taj_e

C3 100n FC-CAP-1019 cap_th_s_rm15x17_5x7x13_5

C4 100n FC-CAP-1019 cap_th_s_rm15x17_5x7x13_5

L1 100n FC-IND-0003 ind_0805

R1 1.2k FC-RES-0356 res_th_a_rm10_16x2_54

R2 22k FC-RES-0001 res_3269w

T1 EI30 FC-TF-0001 ei30_1579

U1 B40C800 FC-REC-0001 rec_b40_tht

U2 LM317 FC-IC-0001 sot223
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Starting Capture
When starting Capture, 
the Session Frame window 
will open.

Start via:
Start > 
Cadence PCB 22.1> 
Capture CIS 22.1
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Start Page
During start, the interactive 
start page gets loaded to 
open existing or to create 
new projects. 
Furthermore, you receive 
additional information such 
as application notes, 
training data, etc.
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Lab: New Project Creation
File > New > Project… creates a new project, in which the design will be stored.

In the top field under Name, please enter the name of your project, i.e. Power_Supply.

In the bottom field Location, please choose the folder in which the new project will be stored.

It is recommended to create a folder for each individual project.

Since we are not planning to simulate, keep Enable project simulation inactive.
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Project Power_supply
A new project with name 
Power_supply and a design with 
same name power_supply.dsn
is created. 

First page of your design with the 
name PAGE1 is opened at the same 
time. 

Please note the folder structure in 
project manager on the left side 
of the picture.

The folder structure is virtual, 
meaning it does only exist inside the 
project manager. PAGE1 under 
schematic can only be found within 
power_supply.dsn file.

In contrast, libraries listed below are 
physical files under displayed paths 
located.
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Setup – Grid Display
In menu item Options > Preferences, please set 
Grid Display to 1/1. This ensures that symbol 
pins are on grid and can be connected easily.

To avoid placing parts off grid, please activate 
Snap to Grid:



14FlowCAD Confidential  │

Setup – Drawing Frames
Appearance of the drawing frames can be configured under Options > Schematic Page Properties. In 
Grid References you can define subdivision of the frame in sections and its width (Capture adjusts frame 
width to grid settings).

Tip

Settings can also be saved to a template that will 
affect all new pages and projects. 
For this purpose, settings can be made under 
Options > Design Template.

More details can be found in chapter Settings and 
Templates starting on page 81.
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Part Search via Database (I)
• The CIS Explorer can be started via pull-down menu with Place > Database Part or via keyboard 

shortcut Z.

• Different database tables can be found in the upper left corner.
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Part Search via Database (II)
• Please open misc_view and select folder Crystal. A table entry appears in the lower window. If this is 

selected, the complete preview of the part is opened (arrangement of windows can be customized). 
The entry under Datasheet is a link to the component data sheet. Double-clicking the green 
highlighted entry causes the part to hang on the mouse and can be placed on schematic page. 

Tip
With keyboard shortcut Z,
CIS Explorer comes to 
foreground again.
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Part Search via Database (III)
• Please open cap_view and select X7R. Several entries appear in lower window. 

• Double-clicking on a column header sorts the list according to this value. 

• If you select the capacitor with 4.7pF in 0603 package, two data sets with manufacturer information 
linked to the part appear in manufacturer table. 

• Graphical representation in schematic can be selected in column Schematic Part.
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Part Search via Database (IV)
• The upper left window has two tabs. Query allows to search for parts using their values. For example, 

4.7pF capacitor can also be found by entering values shown below. Property and Compare fields are 
equipped with drop-down menus that allow easy selection of search options.
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Part Status
• If you go to cap_view category in CIS Explorer, you will see that listed parts are colored differently:

− Standard parts are green
− Obsolete parts are red
− Special parts are black
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Part Placement from Library (I)
Besides the possibility to select parts from a database that provides metadata, OrCAD Capture also 
offers to select and place parts directly from a library (.olb).

• Advantage
− No library database is needed.

• Disadvantage
− All part information must be manually defined as properties (effort, error-prone).
− Variant management is not possible.
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Part Placement from Library (II)
You can use one of three methods to place 
new parts:

• Place > Part... via pull-down menu

• P (keyboard)

• Place Icon on right side

Tip

One of the schematic pages 
must be active to make icon 
panel visible (right edge of 
OrCAD Capture window).
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Part Placement from Library (III)
• Placement command opens the menu as shown.

• In Libraries you can select one or more libraries in which 
your part can be searched. 

• Enter part name in Part. This already behaves as a filter, 
but without usage of wildcards “*”.

• Search results and related library are visible in Part List.

• Search for Part allows a search including wildcards. 

• Add Library         allows to add libraries to search path. 

• Packaging indicates if a part consists of multiple gates or 
slots like a resistor pack or an IC with multiple gates. 

• With a double click in part list you get back into schematic 
and can place the part with LMB (left mouse button).
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Library Assignments
• Choose the necessary libraries for the project.

• Select the desired library and press Add 
button to add the library to the project.

• How to define new parts that cannot be found 
in any existing libraries is described in chapter 
Libraries on page 62.
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Text – Adding and Edit
Pure text notes can be added to the schematic 
with

• Place > Text

• T (keyboard)

• Place Text Icon 

Font and size can be modified during text 
placement with the Change command.
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Connections (I) – Auto Wire
Two Points 
− Two selected pins are automatically connected 

to each other.

Multiple Points
− Multiple selected pins are automatically 

connected to each other.

Connect to Bus
− Multiple selected lines are connected to a bus.
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Connections (II) – Auto Wire
To use the function Two Points, you only need to select two pins or nets. 
Connection get automatically wired. 
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Connections (III) – Manually
Connection can also be done manually:

• Place > Wire

• W (keyboard)

• Place Wire Icon  

For manual connection, user must click for each 
direction change with left mouse button to fix a 
vertex of connection. 

Otherwise this is identical to the Auto Wire 
command.
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Connections (IV) – Procedure
Wiring is performed by a click on an open 
end, marked by a red square on a pin. This 
marker disappears after the connection is 
done.

Red dot signalizes a pin which is available 
for a connection. Another click on this 
object completes connection. Red dot and 
square will disappear. A double click will 
complete the task and release all objects.

Crossroads of connect lines only represent a 
connection between the two lines if a dot or 
a junction is placed or a t-junction is used 
as a interim step. 

By simply selecting a connection and 
pressing Del key, an existing connection 
can be deleted again.

Tip

Ctrl key allows selection of multiple objects at same time.
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Connections (V) – Net Names
Net name assignment

To connect parts on one schematic page, the Place > Wire
command is used to perform wiring.

Another option is using Net Aliases.

Place > Net Alias...

Place Net Alias Icon

A net name is assigned to nets and used to connect two parts. 
Net with name plus is used as an example here 
(see schematic on page 6).

Tip

To connect nets via net names across multiple sheets or even 
across designs, Offpage Connectors or Port Connectors
are used. More details can be found in documentation.
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Edit Properties (I)
After placement and wiring, schematic should look something like this:

It is possible that labeling
of parts (RefDes value)
is not matching schematic
template on page 6.

To correct this, 
values and REFDES
of parts can be edited. 
This also makes sense 
for bill of materials
generated later in the 
process. 

RefDes

Value
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Edit Properties (II)
Edit REFDES and value

The property window can be opened by

Selection (LMB) and RMB > Edit Properties …

or by

Double click

on desired property.

By Display Format different settings related to visibility in 
schematic are possible.

Tip

It is possible to open the property editor for multiple 
symbols, all symbols on one sheet or even for entire design.

• Ctrl + LMB Click or Ctrl + A followed by
RMB > Properties...

• Select Page or Design (.dsn) in Project Manager, 
Edit Object Properties from pull-down menu.
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Packaging – Annotation
Packaging and annotation of parts

On previous page, we have assigned 
reference designators manually. During 
editing, Capture does not verify if duplicated 
reference designators exist (2 x U1, or 3 x 
R5). Verification happens during handover to 
PCB Editor.

By Tools > Annotate… you have the option 
to complete this task automatically without 
any duplicate reference designators. For this 
function many options are available (to make 
command available, you must select .dsn
file in project folder, otherwise Annotate
command is not visible).
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Completed Schematic
After the schematic is adjusted and parts and text got aligned, the completed schematic should look 
similar to the schematic on this page.

Note
At this point we would like to mention 
that because of the used libraries 
assignment of footprints (DIP14, SO14, 
SMD1206, etc.) is not done so far.
This is a later subject, when we import 
the data into layout module.
Just an upfront information:
Footprint assignment has to be done in 
schematic. A missing footprint entry will 
cause an error message during data 
synchronization. If the name is not 
finalized, it is possible to use a dummy 
text string as a placeholder.
Footprints can be predefined in the 
library or by the property editor later.
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Design Rule Check

The DRC is able to identify 
one pin nets, nets without 
input or output. Pre 
condition is a correct 
defined library. 

Please select the 
.dsn file in project folder, 
otherwise the Design Rule 
Check will not be available.
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Bill of Material (BOM)
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Variants – Overview
• Following steps are necessary to create design variants:

− Dividing the design into meaningful groups, for example, according to function blocks
− Creating subgroups that reflect assembly variants of blocks
− Creating BOM variants of entire projects (these are actual variants used by the assembly house)
− Adding subgroups to BOM variants to create the desired assembly

• These steps are explained in detail on the following pages.
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Variants – Part Manager
• Part Manager is used to manage the parts in 

the design, perform database updates or 
generate groups, subgroups and finally the 
variants.

• You can open Part Manager by the right 
mouse button menu on the dsn file.
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Variants – Example Design
• The Capture Quick Start contains a variant sample design:

− ~\Capture_CIS_Schnellstart_22_1\Solutions\VARIANT_DESIGN.DSN
− Groups, subgroups and variants are already preconfigured in this example.
− Creation of variants is described in this chapter.
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Variants – Groups
• To create variants, you need to divide the design into groups.

• It makes sense to store all parts of a function group in one group for variant definition. Function 
groups that do not have any assembly variants remain in common group.

• Select Groups > RMB > New Group. Create a group named Clock. Repeat this process and 
generate a group PCIE.
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Variants – Subgroups
• Next step is to define subgroups that contain different assembly variants of the groups. 

• Select the group Clock > RMB > New Subgroup. 

• Enter Alternate. 

• Repeat this process, and enter HalfMounted and then FullMounted.
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Variants – Assign Parts to Groups
• Open Clock page and select all parts. 

• RMB > Add Part to Group, select the group Clock > Add. 

• Repeat this action with the second page and move all capacitors (not connectors) into group PCIE.
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Variants – Unmounted Parts
• Go to Part Manager and select a subgroup HalfMounted. 

• Select some parts and set them as not present with RMB > Set Part as not present. 

• All unmounted parts are marked with a red cross.

• Repeat this action in another subgroup.
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Variants – Alternative Placement
• Go to Alternate subgroup and select a part, preferably a resistor or capacitor RMB > Link Database 

Part. 

• CIS Explorer opens, and an alternative part can be selected. Make sure that parts have identical 
symbols and footprints. This can be ensured, for example, by a query search in which footprint is 
specified.

• CIS Explorer supports you in your search. Properties with different contents are highlighted in red.

• Link Database Part also works if you select several identical parts in Part Manager. All parts with 
alternative placement are marked with a green tick.
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Variants – Define BOM
• Select BOM Variants > RMB > New BOM 

Variants and enter name BOM1. Repeat for 
BOM2 and BOM3.

• Drag one subgroup per group into BOM. 
Finally, the common group must be added to 
BOM, as it contains the PCIE connector, that 
has not been assigned to any group.

• Variant BOM is shown in the lower right corner.
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Variants – Schematic
• Close Part Manager, go to a schematic page 

with variant description and select View > 
Variant View Mode. Select one of the 
variants. Unmounted parts are displayed in 
grey with lettering DNI, parts with an 
alternative placement are displayed in red. 

• You can set colors via Options > 
Preferences.
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Variants – Report
• You can use Variant Report to check variant 

definitions or compare them with the core 
design. Open Part Manager and select Report 
> Variant Report. Make settings as shown in 
the picture. Select one of the variants > OK. 

• The report is created and displayed. You get a 
direct comparison of core design and variants.
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Variants – Generate BOM
• BOM variants can be generated as shown on page 40 by Report > CIS Bill of Material > Standard. 

• Use an existing template and select one of the variants below.

• You will find Variants Not Stuffed Qty 0 Displayed above list of variants. If you check this box, all 
unstuffed parts are also displayed in the parts list with count 0.

• Click OK to start parts list output. The Variant BOM is displayed.



54FlowCAD Confidential  │Solutions  Downloads  Training  Events  News

Constraint Manager

https://www.flowcad.com/en/solutions.htm
https://www.flowcad.com/en/download.htm
https://www.flowcad.com/en/training.htm
https://www.flowcad.com/en/events.htm
https://www.flowcad.com/en/news.htm


55FlowCAD Confidential  │

Constraint Manager in Capture
• To start Constraint Manager from Capture, please 

use command PCB > Constraint Manager or 
the icon     .

• Confirm query Migrate constraints from 
schematic design with OK.
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Assign Voltages to Power Nets
• In next step, after first start of Constraint Manager, you can assign Voltages to Power Nets.
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Constraint Manager in Capture
• From schematic point of view, mostly definition of electrical constraints makes sense.

• Many constraints require data from layout. This data is available after back annotation from layout.

• You can find more detailed information in the PCB Editor Quick Start starting on page 77.

https://www.flowcad.de/AN/orcad-allegro-pcb-editor-quickstart.pdf
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Generate Layout (I)
By PCB > New Layout logic information is 
transferred to a new PCB.

• PCB Layout Folder: Directory in which design 
sync information is written

• Input Board File: A base or board template

• Board: Newly generated board file
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Generate Layout (II)
• An existing PCB can be updated by PCB > Design Sync.

• Changes are displayed in an ECO list.
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Missing Parts
In this chapter we describe how to search parts in web portals by the Place > Component function and 
also how to create new parts which are not in the OrCAD provided libraries.
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Part Search (I)
• If required parts are not available in present 

libraries, you have the option to search and 
download parts from Ultra Librarian and 
SamacSys web portals. 

• Portals provide datasheets, schematic 
symbols, footprints and step models.

• Select Place > Component to start 
web search.

• To use web portals, a free of charge Cadence 
and Ultra Librarian account is required. 

• Don't have an account? Click here to create a 
new account.
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Part Search (II)
• Unified CIS user interface provides a Google like search.

• The icons on the right side of the result list indicate whether data sheet, schematic symbol, footprint 
and step model are already available.

• By right mouse button and Place or with a click on      the components can be placed.

Schematic
Symbol

Datenblatt Step Model

Footprint
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Part Creation
New parts can also be created with OrCAD Capture capabilities.

Procedure will be demonstrated using LM317 as an example. This part is not available in the already 
connected libraries.
• Counter.olb
• Discrete.olb
• OPAMP.olb

Completed part can be found in: 
• Quickstart.olb
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New Library (I)
You can create new parts in a new library or
open an existing library and add new parts.

Both actions happens by

• File > New > Library

or

• File > Open > Library
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New Library (II)
The new library can be saved in project manager
RMB > Save As... at a desired location.

Afterwards this library can be assigned to your 
existing project.



68FlowCAD Confidential  │

New Part Creation (I)
By Design > New Part...

or

RMB > New Part

you can start creation of a new part in 
a library.
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New Part Creation (II)
Please enter the displayed values into the form.

New Part Name:

Part Reference Prefix:

PCB Footprint:

Part Aliases:
Same symbol, same function, but different package

Parts per package:
i.e. 4 gates in 74LS00

Homogeneous:
Multiple identical circuits, i.e. 74LS00

Heterogenous:
i.e. relay with coil and switch

Part Numbering:
U?A, U?B ... oder U?1, U?2 ...

Click OK.
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Commands in Capture
Commands for part editing are available in the Capture user interface. You can find them in the panel on 
the right boarder of Capture or in the Place pull-down menu.

Hovering over the icons shows 
function as Mouse Over.

On next pages we will explain 
most important functions.
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Adding Pins (I)
Place pins by:

• Place > Pin...

or

• Place Pin Icon
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Adding Pins (II)
The Place Pin panel appears, in which pin 
property definition can be done.

After clicking OK, the pin is attached to the curser 
and ready for placement.

Tip

Using pin type Power allows visible and invisible 
pins.
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Adding Pins (III)
Individual pins get placed. Additional pins can be placed 

by previous menu or by copy / 
paste (Ctrl C, Ctrl V).

Placement of Pins is always 
adjusted to dashed line.

Package und pin properties can 
be modified with property sheet 
shown on the right. 
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Symbol Graphics
Completion of symbols

Symbol outline is drawn finally. Commands are:

• Place > Rectangle

• Place > Polyline

etc.

You can also use icons on right side of the Part Editor window.

Tip

The dashed line is a frame to show real occupied area of 
the symbol on schematic. This frame is invisible in 
schematic.

Rectangle can be selected and stretched or compressed 
over corners. Dashed frame is always at least as large as 
real symbol body. Only during symbol body expansion, 
the rectangle will be adjusted automatically.
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Completed Symbol
Completed symbol LM317

Please do not forget to save!

Tip

Additional text or graphics for this part 
can be added by Place > Text and
Place > Line commands..
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Library Management
Now you can save library1.olb as 
Power_supply.olb. Voltage regulator LM317 is now 
stored in library Power_supply.olb.

If you need more parts, you can create them as well 
in this library.

You can assign this library to design projects as 
described on page 25.

All parts used in this quick start are available in 
library Quickstart.olb.
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Edit Database (I)
• An SQLite editor is required to edit database entries. 

• You can download it here, for example: https://sqlitebrowser.org/dl/

https://sqlitebrowser.org/dl/
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Edit Database (II)
• The desired part table must be opened for editing.

• Commands such as Copy / Paste and New Line are available there.
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FlowCAD Database Solution OMNYA
• FlowCAD offers the database solution OMNYA to manage component date and library elements, as 

well as project data.

OMNYA dashboard in webinterface
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FlowCAD Database Solution OMNYA
• Among others OMNYA offers these possibilities for component management:

− Release of new components / changes by four-eye principle

− Version control and “Where Used” feature for components

− Generic parts, several MPN per part, alternate parts and part assembly

− Integration of component distributors

− Integration in OrCAD Capture

• In addition OMNYA offer:

− Project und BOM Management

• Repository for project data

• Version control of data and Check-OUT, Check-IN

− Library Management

• Version control of schematic symbols and PCB footprints

• “Where Used” functionality for library elements including hierarchical objects (e.g. padstacks, shapes)

• More details about OMNYA at https://www.flowcad.com/de/omnya-integration-platform.htm

https://www.flowcad.com/de/omnya-integration-platform.htm
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Settings and Templates

https://www.flowcad.com/en/solutions.htm
https://www.flowcad.com/en/download.htm
https://www.flowcad.com/en/training.htm
https://www.flowcad.com/en/events.htm
https://www.flowcad.com/en/news.htm
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Design Template – Title Block
You can define pre settings for new projects and 
new pages in an existing project under Options > 
Design Template. 

In tab Title Block you are able to define text 
modules of the title block.



84FlowCAD Confidential  │

Design Template – Page Size
Size of schematic sheet can be defined 
at tab Page Size.

Attention

Settings under Pin-to-Pin Spacing must 
match pin-to-pin spacing used in library. 
This prevents off grid connection 
problems later.
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Design Template – Grid Reference

Grid Reference defines width of 
drawing frame as well as count of 
horizontal and vertical segments.

Width

Separation
Count
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Appendix

https://www.flowcad.com/en/solutions.htm
https://www.flowcad.com/en/download.htm
https://www.flowcad.com/en/training.htm
https://www.flowcad.com/en/events.htm
https://www.flowcad.com/en/news.htm
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System Requirements (Full Version 22.1)
Operating Systems Windows 11 Professional and Enterprise

Windows 10 (64-bit) Professional and Enterprise, including Dark Theme mode;
Windows Server 2016 (All Service Packs)
Windows Server 2019

Hardware Intel Core i7 4.30 GHz or AMD Ryzen 7 4.30 GHz with at least 4 cores
Note: Faster processors are preferred.
16 GB RAM
50 GB free disk space (SSD drive is recommended)
1920 x 1200 display resolution with true color (at least 32 bit color)
A dedicated graphics card supporting OpenGL, minimum 2 GB (with additional 
support for DX11 for 3D Canvas)
Dual monitors (for physical design)
Broadband Internet connection for some service
Ethernet port / card (for network communications and security HostID)
Three-button Microsoft-compatible mouse
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Files in OrCAD Capture
Most important files used by OrCAD Capture:
.OPJ Project 
.DSN Design
.DBK Backup
.OLB Symbol Library
.UPD Property Update File
.DRC Design Rules Check
.BOM Bill of Materials
.EXP Property Export File
.MNL Layout Netlist
.SWP Layout Backannotation
.VHD / .VHO VHDL Source 
.EDF / .EDN EDIF Netlist or Backannotation
.XRF Cross Reference
.NET Other Netlist

Note
• Only design file *.dsn is necessary for sharing or external editing of designs. All design data is 

included in this file.
• Project-File *.opj is meaningful, but not necessary. It contains pre-settings of project as well as used 

libraries, output files, folder settings, etc.
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Please do not hesitate to contact us.
Für weitere Fragen und Informationen stehen wir gerne zur Verfügung.

FlowCAD Deutschland
Mozartstr. 2
85622 Feldkirchen bei München
T +49 89 45637-770
info@FlowCAD.de

FlowCAD Schweiz
Hintermättlistr. 1
5506 Mägenwil
T +41 56 485 91 91
info@FlowCAD.ch

FlowCAD Polska
ul. Sąsiedzka 2A
80-298 Gdańsk
T +48 58 727 90 90
info@FlowCAD.pl

Contact us / Kontakt zu FlowCAD 
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Follow Us

Don’t forget to subscribe, share and like! 

» FlowCAD.com » youtube.com/
FlowCAD

» FlowCAD.com/
newsletter

» linkedin.com/
FlowCAD

» facebook.com/
FlowCAD

» twitter.com/
FlowCAD

» instagram.com/
FlowCAD

» xing.com/
FlowCAD

http://www.twitter.com/FlowCAD
http://www.youtube.com/FlowCAD
http://www.facebook.com/FlowCAD
https://www.xing.com/companies/flowcadeda-softwarevertriebsgmbh
https://www.flowcad.com/
https://news.flowcad.ch/?p=subscribe&id=3
https://www.linkedin.com/company/flowcad/
https://www.instagram.com/flowcad.eda/
https://www.flowcad.com/de/index.htm
http://www.youtube.com/FlowCAD
https://news.flowcad.ch/?p=subscribe&id=3
https://www.linkedin.com/company/flowcad/
http://www.facebook.com/FlowCAD
http://www.twitter.com/FlowCAD
https://www.instagram.com/flowcad.eda/
https://www.xing.com/companies/flowcadeda-softwarevertriebsgmbh
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