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Vorbemerkung – Generell
• Die vorliegende Dokumentation gilt dem Erstanwender des Allegro / OrCAD PCB Editors. Sie soll 

weder als Trainingshandbuch noch als komplette Bedienungsanleitung verstanden werden.

• Da sich diese Anleitung ausschließlich auf den PCB Editor bezieht, erfolgt keine Anleitung zur 
Stromlaufplaneingabe. Als Ausgangspunkt dient ein bereits komplett mit OrCAD Capture erstellter 
Stromlaufplan. Für Capture existiert eine separate Schnellstartanleitung.  

• Aufgrund der Kompaktheit dieser Dokumentation kann natürlich nicht auf alle vorhandenen Befehle 
und deren Feinheiten eingegangen werden. Hierzu ist eine umfangreiche Dokumentation innerhalb 
der Online-Hilfe vorhanden.

• Anhand eines einfachen Schaltplans und eines daraus abgeleiteten Layouts werden die wichtigsten 
Schritte des Designablaufs dargestellt und erläutert, die es dem Erstanwender des PCB Editors 
erlauben, mit einem Minimalaufwand an Einarbeitungszeit die ersten eigenen Aufgaben selbstständig 
zu bewältigen.

• Detaillierte Trainings-Angebote zu den unterschiedlichen Tools finden Sie unter 
https://www.flowcad.com/de/training.htm

https://www.flowcad.com/de/orcad.htm
https://www.flowcad.com/de/training.htm
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Vorbemerkung – Farbschema
• Der PCB Editor lässt sich sowohl in 

einer hellen (light theme), wie einer 
dunklen (dark theme) Darstellung 
betreiben.

• Je nachdem welche Darstellung 
gewählt wird, erscheinen die Icons 
unterschiedlich.

• Das Farbschema lässt sich unter 
Setup > User Preferences > UI > 
General umschalten.

• Für diesen Quickstart wurde das 
helle Schema gewählt.

• Light Theme

• Dark Theme
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• Je nachdem, ob eine OrCAD 
oder Allegro Lizenz verwendet 
wird, ist die Menüstruktur 
anders aufgebaut.

• In diesem Schnellstart wird die 
Allegro-Menüstruktur 
verwendet, da OrCAD mit dem 
Allegro-Menü betrieben 
werden kann.

• Umschalten kann man die 
Menüs unter Setup > User 
Preferences > UI > General.

• OrCAD Menü

• Allegro Menü

Vorbemerkung – Menüstruktur
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OrCAD PCB Design Flow

• Wie in der Grafik zu erkennen ist, setzt sich der OrCAD PCB Designer Flow im Wesentlichen aus 
zwei Teilen zusammen.
− Dies sind das Stromlaufplanpaket Capture und das Layout Programm OrCAD PCB Editor.

• Beide Programmpakete werden natürlich durch weitere Subprogramme ergänzt, die im jeweiligen 
Verbund ein optimales Werkzeug darstellen, das es dem Anwender ermöglicht, sämtliche Aufgaben 
mit maximaler Effizienz zu erledigen.

Capture

AutoRouter
SpecctraRouter

Design
Sync

Schaltungsentwickler OrCAD PCB Editor
Stromlaufplan Board Layout Fertigungsausgabe

Reports

Gerber &
Drill

Footprint
Library

View, Plot

Stücklisten

CIS-DB

Symbol
Library

Layout
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Notwendige Schritte im Schaltplan
• Die in diesem Absatz beschriebenen Schritte dienen nur der kurzen Übersicht.

• Für Capture und Capture CIS gibt es einen eigenen Schnellstart.

• Die Logikinformation ist auch bereits in den Trainingsdaten vorbereitet und kann direkt, wie in der 
Übung Netzlistenimport auf Seite 76 beschrieben, in ein Board-File importiert werden.

• Die für den PCB Editor Schnellstart benötigte Logikinformation ist im Schnellstartdatensatz 
hier zu finden:
~\PCB_Editor_Demo_22_1\PCB_Editor_Demo\project2
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Schaltungsvorlage
Ziel des Design Flows ist es, wie bereits in der Vorbemerkung erwähnt, aus einer bestehenden Schaltung 
ein Leiterplatten-Layout zu erstellen. 
Hier die verwendete Gesamtschaltung des Demo-Beispiels im Überblick.

Nähere Einzelheiten zum Capture 
Flow können dem Schnellstart OrCAD 
Capture entnommen werden. 
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REFDES – Footprints
In der nachfolgenden Aufstellung sind die Footprints aufgeführt, die den einzelnen Bauteilen im 
Schaltplan manuell zugewiesen wurden. 
Footprints sind die Symbole der elektrischen Bauteile, die im Layout Tool verwendet werden.

• T1 = ERA-EI30-2_8VA
• D1 = SM_GL_BRUECKE
• U1 = TO220abv
• R1 = SMR_1206
• R2 = VRES34
• L1 = SML_2220
• C1, C2 = Cpol_508
• C3, C4 = SMC_1206

Es ist auf die genaue Schreibweise zu achten.
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Start von Capture
Nach dem Start von Capture öffnet sich das 
Capture Session Frame Fenster. 

Start über:
Start > Alle Programme > 
Cadence PCB 2022 > Capture CIS

oder

Verknüpfung
Icon auf dem Desktop

Am unteren Rand ist das Session Log Fenster 
eingeblendet. 
Es kann auch separat in einem eigenen Fenster 
dargestellt werden. Hier werden alle Ereignisse 
der aktuellen Sitzung gelistet, einschließlich 
Meldungen weiterer Capture Tools.

File > Open > Project… öffnet ein bestehendes 
Projekt, in welchem das eigentliche Design 
(Power_Supply) definiert ist.
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Layout generieren
Über PCB > New Layout lässt sich die 
Logikinformation in ein neues PCB übertragen.

• PCB Layout Folder: Verzeichnis, in das die 
Design Sync Information geschrieben wird

• Input Board File: Ein Basis oder Board 
Template

• Board: Neu generiertes Board File
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PCB Editor Flow Übersicht
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PCB Editor Flow Übersicht

Component Placement
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Design
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User Interface
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PCB Editor und Arbeitsbereich

Pull-down-
Menüs

Status-
leiste

Icons / 
Toolbars

Title Bar

Kommando 
Fenster

Arbeitsbereich

Control  
Panel(s)

Application Mode

DRC 
Status

Aktive Lage Cursor PositionAktives Kommando
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Icons und Toolbars
Hier sind die im PCB Editor verfügbaren Icons dargestellt. Sie sind in Gruppen, sogenannten Toolbars, 
zusammengefasst.
View > Customize Toolbar erlaubt ein Aus- und Einblenden der Toolbars.
Toolbars können Windows-typisch beliebig an den Außenrändern oder auch separat angeordnet werden.

Route

Place

File Edit Zoom 3D ViewLinie / Text

Fix / Unfix Rats on / off

Undo / Redo

ManufactureShapesSetup (Color, 
Constraints)

Display Update DRC

Hinweis: Wenn die Maus über ein Icon gehalten wird, erscheint ein Tipp zu dem Button.
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Control Panels und World View Fenster (I)
• Options Tab

− Zeigt momentane Parameter und Werte für das 
aktive Kommando

− Zeigt Felder, die es erlauben, das aktuelle 
Kommando zu kontrollieren

• Find Tab (Find Filter)
− Kontrolliert welche Objekte selektierbar sind
− Es können auch Objekte durch Eingabe Ihres 

Namens selektiert werden

• Visibility Tab
− Kontrolliert Sichtbarkeit von Routing Elementen 

(Etch, Pin, Via, DRC) auf Conductor und Plane 
Lagen
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Control Panels und World View Fenster (II)

View Window
• Zeigt den aktuellen Bildausschnitt relativ zum 

gesamten Design 

• Erlaubt auch die aktive Anzeige eines 
Teilbereiches ihres Designs (interaktiv)

Command Fenster
• Erlaubt Koordinaten- / Kommandoeingabe und 

zeigt Systemmeldungen an

Tipp
• Alle Fenster können separat ausgeblendet 

werden, für einen größeren Arbeitsbereich 
(View > Windows oder über           ).

RMB
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Zoom Kontrolle mit mittlerer Maustaste

Zoom Prev

Zoom Out

Zoom by PointsZoom by Points

Zoom OutZoom Out

Zoom FitZoom Cancel

Der Kreis in der Mitte repräsentiert den 
original Selektionspunkt. 1. Klick durch 
die mittlere Maustaste (MMB).

Die Pfeile repräsentieren die Richtung, in 
die die Maus bewegt wird. 
Anschließend 2. Klick (MMB).

Halten Sie die mittlere Maustaste gedrückt und bewegen Sie die Maus. So können Sie den aktuellen 
Bildausschnitt verschieben (pannen).
Wird die Maus nach dem ersten Klick (MMB) nicht bewegt und ein zweiter Klick (MMB) erfolgt, dann 
wird das Kommando Zoom Center ausgeführt.

Die mittlere Maustaste bietet Ihnen ein Universalwerkzeug zum Zoomen und Verschieben Ihrer 
Arbeitsfläche.

4

1 2

3
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Aliases, Funckeys und Strokes
Aliases, Funckeys und Strokes ermöglichen es, komplette Befehle bzw. Kommandos oder ganze Macros 
durch einen einzigen Tastendruck auszuführen.

Versuchen Sie folgende Beispiele als Alias und Funckey Zuweisung und die Stroke Funktion:
1. Laden Sie das Board sample.brd (Ordner Sample).
2. Tragen Sie nacheinander folgende Kommandos in das Kommando Fenster ein und bestätigen Sie mit ENTER:

• alias Home zoom fit (Zuweisung von ZOOM Fit auf Pos1-Taste; Groß- / Klein-Schreibweise beachten)
• funckey r iangle 90 (Zuweisung von 90 Grad Rotation auf R-Taste; Groß- / Klein-Schreibweise beachten)

3. Nutzen Sie die mittlere Maustaste und zoomen Sie in einen kleinen Bereich hinein.
4. Drücken Sie die Taste Pos1 (oder Home bei englischer Tastatur). Das Kommando Zoom Fit wird ausgeführt.
5. Wählen Sie Edit > Move und selektieren Sie ein Bauteil.
6. Drücken Sie die Taste R mehrmals. Der Baustein rotiert um jeweils 90 Grad.
7. Drücken Sie RMB > Done.
8. Drücken Sie die Ctrl-Taste und gleichzeitig RMB. Zeichnen Sie ein kleines Z über einem Baustein.
9. Das Kommando Zoom in wird ausgeführt.

Sie haben erfolgreich eine Alias bzw. Funckey Funktion definiert, und eine Stroke Funktion ausgeführt.
Tippen Sie alias in die Kommandozeile und ENTER. Es werden alle default Aliases und funckeys 
angezeigt. Wählen Sie Tools > Utilities > Stroke Editor. Der Stroke Editor startet und zeigt die 
vordefinierten Strokes.

Tipp
Die beiden obigen Zuweisungen sind nur in dieser Session gültig. Wie Sie derartige Zuweisungen 
dauerhaft einbinden können, erfahren Sie im nächsten Abschnitt.



22FlowCAD Confidential  │Solutions  Downloads  Training  Events  News

Arbeitsumgebung
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PCB Editor Datenstruktur
• Ein Board File (xyz.brd) ist die Zusammenfassung einer Anzahl von Zeichnungslagen. Jeder dieser 

Lagen kann sichtbar und unsichtbar geschaltet werden, und es kann eine Farbe zugeordnet werden.

• Der PCB Editor organisiert diese Zeichnungslagen innerhalb einer Hierarchie von Foldern, Classes 
und Subclasses. Folders sind eine Zusammenfassung von Classes, um den Anwender bei der 
Kontrolle der Farbgebung und Sichtbarkeit zu unterstützen.

• Alle Elemente sind in einer Art 2-Level-Datenbank gespeichert. 
− Das erste Level referenziert auf verschiedene vordefinierte Classes, wobei bestimmte Classes zu speziellen 

Folders zusammen gefasst werden. 
Folders und Classes können weder gelöscht, noch können neue hinzugefügt werden.

− Innerhalb jeder Class existieren mehrere Subclasses. Diese sind das zweite Level der Datenbasis. Sie werden 
häufig als Lagen im Design bezeichnet bzw. betrachtet. 
Vordefinierte Subclasses können nicht gelöscht werden. Allerdings können Sie beliebige neue Subklassen 
hinzufügen. Diese können auch wieder gelöscht werden, solange sie keine Daten enthalten. 

• Alle Kupferstrukturen sind auf Subclasses, die der Class Etch zugeordnet sind. 
− Sie müssen für jede elektrische Lage eines Boards eine entsprechende Subclass hinzufügen. 

Das bedeutet, dass Sie für einen 4-Lagen-Multilayer vier Subclasses unter der Class Etch haben.

• Ein neu erzeugtes PCB Board wird standardmäßig immer als 2-Lagen-Board, bestehend aus Top und 
Bottom, generiert. 
− Die vordefinierten Subclasses Top und Bottom können weder umbenannt noch gelöscht werden. 
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Folders, Classes und Subclasses (I)
Folder Classes Subclasses

Display Temp Highlight, Grids, Ratsnest (top, 
bot, thru), Perm Highlight, Waived
DRCs, Drill holes, Via Label, 
Stacked via Label, Background, 
Pattern, Shading, Transparency

Keine Subclasses

Stackup / 
Conductor

Pin, Via, DRC, Etch, Anti Etch, 
Boundary

Top, Bottom 
(und alle anderen user definierten Boarddesign-Lagen)

Stackup / 
Non_Conductor

Pin, Via, DRC, Etch, Anti Etch, 
Boundary

Soldermask_Top, Soldermask_Bottom, Pastemask_Top,
Pastemask_Bottom, Filmmasktop, Filmmaskbottom,
Through All, Package_Top, Package_Bottom

Areas Route Keepout, Via Keepout, 
Package Top, Bottom, Through All, 
Package Keepout, Package Keepin, 
Route Keepin, Constraints Region

Top, Bottom, Inner_Plane_Layers, Inner_Signal_Layers, 
Outer_Layers, Through All

Board Geometry Board Geometry Outline, Plating_Bar, Assembly Notes, Tooling_Corners, 
Dimension, Place_Grid_Top, Place_Grid_Bottom, 
Top_Room, Bottom_Room, Both_Rooms, 
Switch_Area_Top, Switch_Area_Bottom, Silkscreen_Top,
Silkscreen_Bottom, Assembly_Detail, Soldermask_Top, 
Soldermask_Bottom, Off_Grid_Area, NcroutePath, 
Wb_Guide_Line
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Folders, Classes und Subclasses (II)
Folder Classes Subclasses

Package 
Geometry

Package Geometry Assembly_Top, Assembly_Bottom, Place_Bound_Top,
Place_Bound_Bottom, Pin_Number, Pad_Stack_Name,
Silkscreen_Top, Silkscreen_Bottom, Body_Center,
Soldermask_Top, Soldermask_Bottom, Display_Top,
Display_Bottom, Modules, Dfa_Bound_Top, 
Dfa_Bound_Bottom, PasteMask_Top, PasteMask_Bottom

Embedded 
Geometry

Embedded Geometry All

Components Comp Value, Device Type, Ref Des, 
Tolerance, User Part Number

Assembly_Top, Assembly_Bottom, Display_Top,
Display_Bottom, Silkscreen_Top, Silkscreen_Bottom

Manufacturing Manufacturing Autosilk_Top, Autosilk_Bottom, Ncdrill_Legend, 
Ncdrill_Figure, No_Gloss_All, No_Gloss_Top, 
No_Gloss_Bottom, No_Gloss_Internal, No_Probe_Top, 
No_Probe_Bottom, Photoplot_Outline, Probe_Top, 
Probe_Bottom, Xsection_Chart

Drawing Format Drawing Format Drawing_Origin, Outline, Revision_Block, Revision_Data,
Title_Block, Title_Data

Analysis Analysis Low_Isocontour, Medium1_Isocontour, 
Medium2_Isocontour, Medium3_Isocontour,
High_Isocontour, Pcb_Temperature
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Folders, Classes und Subclasses (III)
Um weitere Lagen (Subclasses) dem PCB hinzuzufügen, ist im Pull-down-Menü über Setup > 
Subclasses die gewünschte Klasse auszuwählen und im nachfolgenden Fenster der Namen der neuen 
Subclass anzugeben.

Mit Ausnahme der Routing-Lagen (Etch) 
werden alle User-defined Lagen über 
diese Menüs eingetragen. 
Wenn Sie ETCH wählen, wird automatisch der Layer-Stackup gestartet, über den zusätzliche Routing-
Lagen definiert werden. Näheres dazu auf Seite 72. 

Alle User-defined Lagen sind weiß hinterlegt, so dass Sie über diese Menüs auch 
gleichzeitig erkennen, welche Lagen von einem User hinzugefügt wurden. 
Alle anderen Lagen sind Default-Lagen des Systems. 
Das Löschen einer User-defined Lage erfolgt über einen Klick auf das Dropdown.
Es können nur Lagen gelöscht werden, die keine Daten enthalten! 
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Kontrolle von Color und Visibility (I)
Mit Display > Color > Visibility oder kann die Sichtbarkeit und die Farbe der einzelnen Lagen 
(Classes / Subclasses) eingestellt werden.

Folder

Class

Subclasses

Pattern-
Auswahl

Farb-
auswahl
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Kontrolle von Color und Visibility (II)
Mit Display > Color > Visibility oder kann die Sichtbarkeit und die Farbe der einzelnen Lagen 
(Classes / Subclasses) eingestellt werden.

Color / 
Visibility
der Design 
Layer

Farbzuordnung
zu Netzen

Generelle Display-
Einstellungen
der Arbeitsfläche

User-definierte Favoriten
(durch RMB Klick im Layer Tab)

Definition des
Visibility Pane

Tipp
Unter den Display-Einstellungen sind Funktionen wie Shadow Mode und Transparency zu finden, mit 
denen sich die Darstellung des Designs individuell anpassen lassen.
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Option Fenster des Control Panels
Die Parameter im Option Fenster sind abhängig vom jeweiligen Kommando und bieten eine Vielzahl von 
Optionen für die jeweiligen Kommandos. Daher sollte das Option Fenster während der normalen 
interaktiven Arbeit immer im Auge behalten werden.

Änderungen, die Sie hier vornehmen, werden sofort wirksam. Sie überschreiben auch Voreinstellungen, 
die im Setup des PCB Editors vorgenommen wurden, z. B. über Setup > Design Parameters… > 
Design > Linelock / Symbol. 

Edit > ChangeRoute > Connect Add > Text
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Visibility Control Panel
Das Visibility Control Panel bietet eine sehr schnelle Möglichkeit, einzelne Lagen aus- oder 
einzuschalten. Die Lagenkontrolle hinsichtlich der einzelnen Elemente bezieht sich allerdings nur auf die 
Kupfer- und Masken-Lagen. Für die anderen Lagen können Sie das Color Dialog Fenster        oder die 
User-definierten Color Views benutzen.

Exclude / Include Lagen

Kontrolle
Conductor-, Plane- und 
Mask-Lagen

Individuelle
Lagenkontrolle

Individuelle Elementkontrolle

User-definierte
Color Views
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User Preferences
Über Setup > User Preferences… können Sie das Verhalten des PCB Editors und auch viele 
Voreinstellungen definieren.

Die beiden wichtigsten Einstellungen sind 
psmpath und padpath.  Nur wenn diese richtig 
gesetzt sind, können Bauteile aus der Library 
platziert werden.

Das Bild zeigt die Default Einstellung, die Sie 
am Anfang möglichst unverändert lassen sollten.

Sämtliche Default Einstellungen des PCB 
Editors sind in einem File namens env unter
< Ihre_Installation > /share/pcb/text
abgespeichert.

Sobald Sie dieses Menü aufrufen und eine 
Änderung vornehmen, wird in Ihrer Home 
Directory ein Ordner PCBENV erstellt, 
der ebenso eine env-Datei enthält. 
In dieser können Sie dann z. B. Ihre 
persönlichen Aliases und Funckeys definieren. 
Bei jedem Neustart des PCB Editors wird diese 
env-Datei automatisch gelesen.
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Bibliothek

https://www.flowcad.com/de/solutions.htm
https://www.flowcad.com/de/download.htm
https://www.flowcad.com/de/training.htm
https://www.flowcad.com/de/events.htm
https://www.flowcad.com/de/news.htm


33FlowCAD Confidential  │

Bibliothekselemente
Bibliotheken, die für das Layout erforderlich sind bzw. dort Verwendung finden, können verschiedene 
Elemente enthalten. Hier ein kurzer Überblick über diese Elemente und deren Bedeutung:

• Package Symbol (.psm) Footprint (DIP14, SOIC16, etc.), Package Symbol
• Padstack (.pad) Lötaugen- und Bohrdefinition der Anschlusspins auf den einzelnen Lagen
• Mechanical Symbol (.bsm) Mechanisches Symbol, z. B. Abstandhalter, vordefinierte Außenkontur eines 

Boards, evtl. mit Befestigungsbohrungen und ähnlichem
• Format Symbol (.osm) Zeichnungsrahmen für Dokumentation, darf keine Pins enthalten
• Shape Symbol (.ssm) Vordefinierte Kupfergeometrie z. B. für spezielle Pad-Formen
• Flash Symbol (.fsm) Kupfergeometrie für Thermalanschlüsse auf Plane-Lagen (für Wärmefallen)
• Boardtemplate (.brd) Board Vorlage mit Außenkontur, Technologie (Stackup, Spacings, …) und 

weiteren Voreinstellungen

Padstack und Package Symbol werden auf den nachfolgenden Seiten näher erläutert.
Alle aufgeführten Symbole werden unter Verwendung der Symbol Editoren als .dra bearbeitet und 
gespeichert und in der kompilierten Form .psm, .bsm, .osm, .ssm, .fsm files dem Layout zur Verfügung 
gestellt.
Die verschiedenen Symbol Editoren basieren alle auf dem OrCAD PCB Editor und weisen identische 
Bedienung auf. Lediglich der Funktionsumfang unterscheidet sich.
Da im .dra-File auch die Definition enthalten ist, um welchen Symboltyp es sich handelt, startet beim 
Laden eines .dra-Files gleich der richtige Symbol Editor. Für die Padstacks existiert ein separater 
Padstack-Editor. Auf der folgenden Seite ist eine Übersicht über die verschiedenen Symbol Editoren.
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Editoren-Übersicht

OrCAD PCB Designer

Symbol Editoren

.brd

U*

U*

Design Layout

Manufacturing 
Outputs

Padstack Editor

.pad

.fsm

.dra

Flash

Format

.psm

.dra

Mechanical

Package

.osm

.dra

.bsm

.dra

U*

Shape

.ssm

.dra
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Footprint als Basic Symbol
Die Symbol Editoren dienen der Erstellung der für das Layout erforderlichen Bibliothekselemente.
Stellvertretend wird hier das wichtigste Element, der Footprint, etwas näher erläutert.

Daneben gibt es reine grafische Symbole für Dokumentations- oder Fertigungszwecke (Firmenlogos, 
Zeichnungsrahmen, Passermarken), die ebenfalls über einen der Symbol Editoren erstellt werden 
können.

Assembly
Footprint

Padstack

Kupferpad

Bohrung
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Bibliothekswerkzeuge
Symbol Editor

Padstack Editor



37FlowCAD Confidential  │Solutions  Downloads  Training  Events  News

Padstacks
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Padstack (Aufbau)
Das wichtigste Element eines Footprints ist das Padstack.
Das Padstack definiert die geometrische Form eines Lötauges auf jeder einzelnen Lage einer Leiterplatte 
sowie den Durchmesser der Bohrung, die den bedrahteten Pin eines Bauteils aufnimmt. 
Man unterscheidet im Wesentlichen zwei Typen von Padstacks:

Through-Hole Padstack

Mask

Top

Inner

Bottom

Mask

Drill-Size

Surface-mount Padstack

Paste

Mask

Top

Die Pad Größen werden für alle Lagen (elektrisch und nichtelektrisch) im 
Padstack-Editor definiert. Elektrische Lagen sind alle Signal- und Plane-
Lagen. Nichtelektrische Lagen sind Soldermask, Pastemask sowie Filmmask, 
wobei letztere beliebig verwendet werden kann. Default Routing Lagen sind 
BEGIN Layer, DEFAULT INTERNAL und END Layer. 
Die DEFAULT INTERNAL Definition wird standardmäßig benutzt, wenn 
zusätzlich zu TOP und BOTTOM weitere Innenlagen hinzugefügt werden.
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Padstack (Details)
• Regular Pad

Ein Pad mit einem regulären Shape (circle, 
square, rectangle, oblong, octagon), wie sie im 
Dropdown verfügbar sind.

• Shape Symbol
Wenn nicht im 
Dropdown verfügbare 
Padgeometrien
verwendet werden soll, 
können diese einfach als 
Shape gezeichnet 
werden. 
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Pad Designer – Start
Start des Padstack Editors kann erfolgen über:
• Start > Cadence PCB Utilities > PCB Editor Utilities 2022 > Padstack Editor 2022
oder direkt aus dem PCB Editor bzw. Symbol Editor:
• Tools > Padstack > Modify Design / Library Padstack…

Auf der Start Seite können die 
verschiedenen Padstack-Typen 
ausgewählt werden. Basierend auf der 
Auswahl, sind die weiteren Tabs 
verfügbar und bereits vorbereitet.

Vorschau Top

Vorschau Seite
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Pad Designer – Drill
Im Drill Tab lassen sich alle notwendigen Einstellungen der Bohrungen definieren. 

Neben Durchmesser und Toleranzen 
kann auch die Bohrungsart (z. B. Laser) 
festgelegt werden.

Des Weiteren ist es möglich 
unterschiedliche Pattern zu definieren.
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Pad Designer – Secondary Drill
Im Secondary Drill Tab lassen sich alle notwendigen Einstellungen für Senkbohrungen definieren. 

Neben Durchmesser und 
Toleranzen kann für die 
Senkbohrungen auch ein eigenes 
Symbol festgelegt werden.

Darüber hinaus besteht ab OrCAD 
Professional auch die Möglichkeit 
Backdrilling zu definieren. 
Auf den Backdrilling-Prozess wird in 
diesem Schnellstart nicht weiter 
eingegangen.
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Pad Designer – Drill Symbol
Im Drill Symbol Tab werden die Symbole definiert, die für die Bohrung in der Bohrungszeichnung 
verwendet werden.
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Pad Designer – Drill Offset
Im Drill Offset Tab kann bei Bedarf ein Offset zwischen dem Pad und der Bohrung eingestellt werden.



45FlowCAD Confidential  │

Pad Designer – Design Layers
Neben den Tabs zur Definition der Bohrungen ist der Design Layers Tab der wichtigste im 
Padstack Editor.

Hier werden die eigentlichen 
Kupferpads definiert. Dabei können 
unterschiedliche Geometrien 
ausgewählt und die zugehörigen 
Maße definiert werden.

Hinweis
Im Design Layer Tab ist es auch 
möglich Thermal- und Antipads zu 
definieren. Diese braucht man 
heutzutage nicht mehr, da sie nur 
auf negativen Kupferlagen 
Verwendung finden.
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Pad Designer – Mask Layers
Im Mask Layers Tab werden die verschiedenen Maskenlagen definiert.

Neben der Aussparung im 
Lötstopplack können 
Lotpastendruck und bei 
Bedarf die Aussparungen in 
anderen Maskenlagen 
eingestellt werden.
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Pad Designer – Options / Summary
In Options Tab sind einige zusätzliche 
Optionen, die hier nicht weiter betrachtet 
werden sollen.

Der Summary Tab gibt eine 
Zusammenfassung der verschiedenen 
Lagen, Bohrungen und zusätzlichen 
Einstellungen, die zu Dokumentations-
zwecken auch im html-Format 
ausgegeben werden können. 
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Übung: Padstack (Start)
Im Folgenden wird der Ablauf einer Padstack Generierung anhand eines Through Hole Padstacks gezeigt.

1. Start > Cadence PCB Utilities > PCB Editor Utilities 
2022 > Padstack Editor 2022

2. File > New im Padstack Editor
3. Es erscheint nebenstehendes Browser Fenster.
4. Navigieren Sie mit dem Browse Button zu Ihrem 

gewünschten Ordner (hier Play).
5. Tragen Sie den Padstack-Namen 60c38d ein.
6. Aktivieren Sie die Change Directory Box. 

Hiermit wird der gewählte Ordner Ihr Arbeitsordner.
7. Speichern Sie den neuen Padstack. 

Durch das Selektieren der Checkbox unter 5. wird 
Play als aktueller Arbeitsordner definiert.

8. Die Titelzeile des Pad Designers zeigt nun Name und 
Pfad an.

Hinweis
Die Namenskonvention von Cadence bezieht sich auf Units in mil: 60c = 60 mil circle; 38d = 38 mil
Bohrung (Enddurchmesser); weiterhin:  r = Rectangle; s = Square; o = Oblong 
Diese Notation wird in allen von Cadence gelieferten Padstacks verwendet und erleichtert 
die Wiedererkennung.
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Übung: Padstack (Drill)
Bitte tragen Sie die 
nebenstehenden Werte im 
Drill Tab ein.

Tipp
Um keine notwendigen 
Eintragungen zu übersehen, 
gehen Sie die Tabs von links 
nach rechts durch.
Bei einem Padstack-Typ 
nicht verwendete Tabs
sind ausgegraut.
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Übung: Padstack (Design Layers)
Bitte tragen Sie die 
nebenstehenden Werte im 
Design Layers Tab ein.

Tipp
Über rechte Maustaste 
Copy / Paste lassen sich 
Pads von einem zum 
anderen Layer innerhalb 
eines Tabs kopieren.
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Übung: Padstack (Design Layers)
Erstellen Sie entsprechende Pads auch im Tab Mask Layers.
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Übersicht Footprint Design Prozess
Die Generierung eines neuen Footprints umfasst im Wesentlichen die nachfolgenden Schritte:
• Definition von Units, Nachkommastellen und Größe der Arbeitsfläche
• Definition des Nullpunkts, der typischerweise später der Fangpunkt des Bauteils während der 

Platzierung ist.
• Grid Raster definieren (erleichtert die Cursorpositionierung mit der Maus).

Über die Tastatur ist trotzdem jeder x-beliebige, krumme Wert eingebbar.
• Platzieren der Pins (vorher definierte Padstacks)
• Assembly und Silkscreen Outline definieren
• Platzierungsbedarf des Bauteils festlegen (Placebound_Top / Bot)
• Evtl. Höhenvorgabe der Placebound_Top / Bot übergeben
• Bauteiltexte hinzufügen bzw. modifizieren (REFDES, DEVICETYPE, etc.)
• Speichern in gewünschter Bibliothek

Die Schritte sind auf den nächsten Seiten am Beispiel eines Trafos genauer erläutert. Das Datenblatt für 
das Beispiel ist im PCB Editor Demo-Verzeichnis zu finden: Datenblatt_Trafo.pdf.
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Übung: Symbol (Start)
Den Package Symbol Editor kann man üblicherweise nur aus einem bereits geöffneten PCB Editor über
File New > Package Symbol starten. In der Maske lässt sich der Name des neuen Footprints definieren.

Bitte als 
Beispielname:
ERA-EI30-2_8VA
eingeben und mit 
Browse im Ordner 
Play speichern.
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Übung: Symbol (Setup)
Über Setup > Design Parameters…> Design
können Sie die Units, die Nachkommastellen, 
die Arbeitsfeldgröße sowie dessen Nullpunkt 
festlegen. 
Mit Move Origin lässt sich der Nullpunkt 
verschieben. Die Arbeitsfeldgröße bleibt erhalten. 
Der Nullpunkt lässt sich auch per Maus über 
Setup > Change Drawing Origin verändern.

Bitte setzen Sie folgende Werte für das Beispiel:
− Units: Millimeter
− Size: Other
− Accuracy: 1
− Left X: -30.0
− Lower Y: -30.0
− Width: 100.0
− Hight: 80.0
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Übung: Symbol (Grids)
Grids lassen sich mittels Setup > Grids… 
einstellen. Für das Beispiel bitte die Werte aus 
dem Screenshot verwenden.

Tipp
Es gibt zwei getrennte Grid-Definitionen:
• Non-Etch für die Bauteilplatzierung
• All Etch für das Routing
X und Y können unterschiedlich sein.
Die Etch-Lagen (Top, Bot und weitere Innenlagen) 
können auch unterschiedliche Grids aufweisen.
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Beachten Sie bitte, dass im Symbol Editor in der Regel immer von der Draufsicht ausgegangen wird.
1. Über Layout > Pins lassen sich Pins hinzufügen.

Übung: Symbol (Pins I)

Alle Pins werden als Connect Pins platziert, da sie eine 
elektrische Funktion erfüllen sollen.
Das Padstack wählen wir über den Browser, aus der 
vorhandenen Bibliothek aus. 
Über die Angabe einer Quantity und zugehörigem Spacing lässt 
sich eine Matrix von Pins setzen. In dieser Übung beschränken 
wir uns auf 2 Pins.
Die Pins können durch klicken im Arbeitsbereich oder durch 
Koordinateneingabe gesetzt werden.
Am einfachsten und genauesten ist die Koordinateneingabe 
X -10 -10 im Kommandofenster und Enter.
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Übung: Symbol (Pins II)

2. Das Add Pin-Kommando ist noch aktiv, am Cursor 
hängt Pin 3 zum Platzieren.

3. Wir wiederholen die Übung für die beiden oberen Pins. 
4. Der erste der beiden Pins soll dabei auf x -5 10

abgesetzt werden. 
5. Schließen Sie den Befehl mit RMB > Done ab.

Platzieren der weiteren Pins (2 bis 5 und 6 bis 10) entsprechend der Angaben im Datenblatt.
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Übung: Symbol (Pins III)
Laut Datenblatt und Stromlaufplan sind nur die Pins 1, 5, 7, 9 in dem Trafo in Verwendung.

1. Benennen Sie die Pins entsprechend 
des Datenblattes mit Edit > Text um.
Dabei bitte auf den Find Filter achten. 

Tipp
Eine andere Möglichkeit zur richtigen Pin 
Nummerierung zu kommen, ist es 
vollständige Pin Reihen zu setzen und 
die überflüssigen Pins zu löschen.
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Übung: Symbol (Assembly Outline)
Im nächsten Schritt wird dem Symbol eine Assembly Outline (üblich für Bestückungsplan) hinzugefügt.
Um ein besseres Zeichnen zu ermöglichen, sollte das Grid weder zu groß noch zu klein gewählt werden.

1. Setup > Grid, das Define Grid Fenster erscheint.
2. Tragen Sie in der Non-Etch Sektion für x und y z. B. 0.5 ein. Beachten Sie, dass der Zahlenwert in 

den Units interpretiert wird, auf die der Editor eingestellt wurde. Wir arbeiten im Moment mit Millimeter.
3. Klicken Sie OK.
4. Zoomen Sie etwas heraus, um die Assembly Outline besser setzen zu können.
5. Wählen Sie vom Hauptmenü Add > Line, um einen Polygon zu zeichnen.

Achten Sie darauf, dass im Option Fenster die aktive Lage korrekt 
gewählt ist. Der Wert für Line width steht für die Strichstärke in der 
späteren Dokumentation. Die Strichstärke 0 würde in der Ausgabe 
nicht erscheinen. 
Geben Sie also einen relevanten Wert (z. B. 0.1) an.  

6. Zeichnen Sie ein Rechteck mit den Abmaßen X=33 und Y=28 
(0.5 mm Toleranz für Bestückung wurden hinzugefügt).

7. Klicken Sie nacheinander LMB auf -15 -13, 15 -13, 15 13, -15 13, 
-15 -13

8. Klicken Sie RMB und Done. 
9. Sie können diese Werte auch wie folgt in der Kommandozeile eingeben:

x -15 -13, x 15 -13, …
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Übung: Symbol (Silkscreen Outline)
Im jetzt folgenden Schritt soll die Silkscreen Outline 
(Leiterplatten-Siebdruck) hinzugefügt werden.

1. Am einfachsten geht das über Dimension / 
Drafting > Add Parallel Line.

2. Dabei in den Optionen den gewünschten Offset 
und die Wiederholungen einstellen.

3. Anschließend ändern wir den Layer über Edit > 
Change auf die richtige Subclass. 
Bitte dabei auch darauf achten, das nur der 
Hacken bei New Subclass gesetzt ist.



62FlowCAD Confidential  │

Übung: Symbol (Platzhalter)
In jedem Footprint muss das Label REFDES vorhanden sein. 
Die Definition weiterer Platzhalter für Labels ist sinnvoll, die zur 
Anzeige logischer Informationen verwendet werden. Im PCB Editor 
können insgesamt fünf Labels vordefiniert werden:
• REFDES (Referenz-Nr. des Bauteils, R1, C2, usw.)
• DEVICE (Devicename aus Packager)
• VALUE (Wert des Bausteins, z. B. 10 K für Widerstand)
• TOLERANCE (Toleranz, falls angegeben)
• PART NUMBER  (Sachnummer für Lagerhaltung)

1. Layout > Labels > REFDES
Beachten Sie die Voreinstellung der erforderlichen Lagen.
Das System fragt Sie nach der gewünschten Position.

2. Klicken Sie innerhalb der Assembly Outline, das System fragt 
nach einem Text String.

3. Tragen Sie z. B. T* ein. Dieser String wird später komplett durch 
den richtigen REFDES ersetzt.

Tipp
Beachten Sie die Optionen Marker Size, Rotate, Text Block, Text 
Just. Diese sind wichtig für die richtige Größe und Ausrichtung 
der Textstrings.
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Übung: Symbol (Package Boundary)
Der Design Rule Check (DRC) benutzt die Package Boundary, um ein Überlappen der Bauteile beim 
Platzieren zu prüfen und als Fehler anzuzeigen, oder auch um das Platzieren in falsche Bereiche 
(Keep Out Areas) zu verhindern.

1. Setup > Areas > Package Boundary vom Hauptmenü.
2. Package_Geometry und Place_Bound_Top werden 

automatisch als Lage gesetzt.
Definieren Sie die Größe als Worst Case bezüglich 
des Datenblattes.

3. Klicken Sie LMB, um den Polygon für die erforderliche 
Platzierungsfläche zu generieren. Wenn der Polygon mit 
RMB > Done abgeschlossen ist, wird dieser 
automatisch gefüllt dargestellt.
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Symbol (Package Boundary)
Noch einige Hinweise und Tipps 
zur Package Boundary:
− Wenn Sie die Package Boundary nicht selbst 

generieren, erzeugt sie das System selbst 
beim Abspeichern. Allerdings werden damit 
natürlich nicht zwangsläufig die wirklichen 
Toleranzen berücksichtigt. 

− Eine andere Möglichkeit die Package 
Boundary zu erzeugen, ist es diese mit Edit > 
Z-Copy Shape abzuleiten.

− Dabei können Sie in den Options die neue 
Subclass und auch eine Aufweitung unter 
Expand einstellen.
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Übung: Symbol (Package Height I)
Das DRC Programm nutzt die Package Height Info, 
um die Bauteilplatzierung auf dem Board in Verbindung mit 
vordefinierten Bereichen, die eine Restriktion haben, zu 
überprüfen bzw. zu kontrollieren. Sie wird der Package 
Boundary als Property Max Height und / oder Min Height
zugewiesen. 
Es ist nicht erforderlich die Höheninformation für jedes Bauteil 
zu definieren. In diesem Fall kann eine default Höhe, die im 
PCB Editor definiert wird, verwendet werden (Setup > Design 
Parameters… > Design > Symbol).

1. Setup > Areas > Package Height vom Hauptmenü
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Übung: Symbol (Package Height II)
2. Selektieren Sie die Package Boundary 

(gefüllter Polygon).
Tragen Sie die Höhe des Trafos von 29 mm in 
das Max Height Feld ein.
Min Height ist hier nicht relevant. Wenn auch 
eine minimale Höhe eingegeben wird, können 
Bauteile übereinander platziert werden, wenn 
ihre Höhen dies zulassen.
RMB > Done, um das Kommando 
abzuschließen.

3. Speichern Sie das Bauteil mit File > Save.
Das System speichert ein .dra-File, und ein 
.psm-File. 
Das .psm-File wird im Editor während des 
Placements benutzt.
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Step Mapping
Zusätzlich zur Höheninformation die auf die Place Bound gehängt wird, ist es im 3D Canvas möglich ein 
Step Model auf das Bauteil zu mappen.

Die Auswahl des Step
Models erfolgt mit dem 
Browse Button.
Das Mapping geschieht 
automatisch und kann 
bei Bedarf manuell 
nachbearbeitet werden.
Im gezeigten Bild ist das 
Step Model eines 1206 
Kondensators gemappt.
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Speicherort Pads und Symbole
Die im Symbol Editor erzeugten .dra- und .psm- sowie die im Padstack Editor erzeugten .pad-Files 
müssen in den psm- und pad-Path (in den User Preferences gesetzt) gespeichert werden, damit der PCB 
Editor sie zum Platzieren findet.
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Board Übersicht
In einem Board werden die in den anderen Editoren erzeugten Elemente genutzt. Hier eine Übersicht, 
welche Elemente in ein Board einfließen. Wie Board Vorlagen aufgesetzt werden, wird in einem späteren 
Kapitel erläutert.

(.osm)

(.psm)
Cross section (stackup)

Design rules

PCB Editor (.brd)

(.bsm)

Tipp
Im Solution Ordner sind verschiedene Stände der Übungs-Boards vorhanden. 
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Übung: Board Setup
Auf den folgenden Seiten werden die wichtigsten Schritte aufgeführt, um ein Board aufzusetzen.

1. File > New vom Hauptmenü
2. Tragen Sie master in das Drawing Name Feld ein.
3. Wählen Sie den Drawing Type Board.
4. OK
5. Setup > Design Parameters… > Design
6. Ändern Sie die Werte entsprechend der Drawing 

Parameter Dialog Box (links).
7. OK

Tipp
Die Drawing Extents sollten so groß 
gewählt sein, dass auch 
Zusatzelemente, wie ein 
Zeichnungsrahmen, Legenden usw., 
Platz haben. 
Sind die Drawing Extents kleiner als 
zu platzierente Elemente, erhalten 
Sie eine Fehlermeldung.
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Der Lagenaufbau des Boards wird mit dem Cross Section Editor definiert, der über Setup > Cross 
Section oder        zu erreichen ist. Über rechte Maustaste auf einer vorhandenen Lagen lassen sich 
Lagen hinzufügen und entfernen.

Übung: Lagenaufbau

Der Name der Layer TOP und BOTTOM ist nicht veränderbar. Zusätzlichen Lagen können beliebigen 
Namen erhalten. Die hier gewählten Namen erscheinen auch im Visibility Fenster.
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Übung: Board Outline
Über Setup > Outline > Design Outline wird die Außenkontur 
der Leiterplatte definiert.
Unter Design edge clearence kann dabei ein Wert 
eingegeben werden, um den die Schutzzonen Package 
Keepin und Routing Keepin innerhalb der Boardkontur
verkleinert werden. Die Keepins können bei Bedarf 
anschließend manuell angepasst werden.
Auf der nächsten Seite wird auf eine Board Vorlage 
zurückgegriffen, die in den Übungsdaten vorgefertigt ist.
Wenn Sie die Board Outline nicht selbst definieren wollen, 
können Sie auf die vorhandene Outline zurückgreifen.
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Übung: Boardsymbol platzieren

In das noch offene Masterboard start.brd
laden wir das Boardsymbol wie folgt:
1. Place > Manually vom Hauptmenü,

es erscheint die Placement Box (rechts).
2. Selektieren Sie unter Advanced Setting

beide Optionen Database und Library.
3. In der Placement List expandieren Sie 

Mechanical Symbols und selektieren Sie 
Outline (selbst definiertes Symbol).

4. In der Kommandozeile tragen Sie x 0 0 ein 
und Enter.

5. RMB > Done. Das mechanische Symbol 
ist platziert.

6. File > Save As.
Es wird ein master.brd-File gespeichert.

7. PCB Editor nicht schließen!

Im Demo-Datensatz ist ein Boardsymbol enthalten, das als Basis für die weiteren Übungen genommen 
werden kann.
In einem späteren Absatz wird auch noch darauf eingegangen, 
wie Board Vorlagen erstellt werden.
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Übung: Import der Logik
Dieser Bereich zeigt Ihnen, wie Sie die Schematic Daten von Design Entry Capture in den PCB Editor 
bringen. Vorab ein paar wichtige Informationen zur nachfolgenden Übung:
• Der Stromlaufplan ist bereits vollständig erstellt.
• Die erforderlichen Transferdaten sowie der Stromlaufplan selbst stehen als Muster im Ordner 

Project2 zur Verfügung. 

1. Wir laden mit File > Import > Logic die 
Logikdaten in das start.brd-File.

2. Selektion des Import Logic Type Design 
Entry CIS.

3. Setzen der richtigen Import Directory 
<Path>\PCB_Editor_Demo\project2.

4. Import Cadence
(evtl. wird fehlerhafter Import gemeldet).

5. File > Save As…  (netlist.brd) 
Nicht schließen!!
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Designregeln
Vor dem Platzieren von Bauteilen sollten im Design einige grundsätzliche Regeln definiert werden, um 
z. B. das Platzieren selbst zu überwachen. Zusätzlich werden wir gleich einige Designregeln, die für das 
Routen erforderlich sind, mit definieren. Der Umfang der vorhandenen Rules und Möglichkeiten der 
Definition ist von der verwendeten Lizenz abhängig.
Alle Designregeln werden im Constraint Manager verwaltet und gliedern sich in folgende Kategorien:
• Electrical Rules: Designregel, die die elektrischen Eigenschaften charakterisieren, Impedanz,

Topologie, …
• Physical Rules: Definition von physikalischen Regeln wie Linienbreiten, Vias, …
• Spacing Rules: Abstandsregeln, z. B. zwischen Linien, Pads, Vias, Kupferflächen (Shapes), …
• Same Net Rules: Abstandregeln zwischen Elementen des gleichen Netzes
• Manufacturing: Fertigungsrelevante Regeln, wie Bauteilabstände, Maskenstege, Restringe

Die Regeln gliedern sich grundsätzlich in zwei Level:
• Standard Rules: Immer vorhandener (Default) Regelsatz, der für die Mehrzahl der Netze verwendet 

wird. D. h. für alle Netze, die keine spezielle Regelzuweisung haben.
• Special Rules: Nutzerdefinierte Regelsätze, die vom Standard abweichen und meist nur für einige 

Netze gelten, z. B. Power, kritische Signale.

Neben den Design Rules sind im Constraint Manager auch einige der auf Netzen und Bauteilen 
zugewiesenen Properties gelistet.

https://www.flowcad.com/de/white-paper-CM.htm
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Constraint Manager Übersicht
Gestartet wird der Constraint Manager über Setup > Constraints > Constraint Manager… oder 

Constraint 
Domains
Constraint 
Sets

Constraint 
Assignment

Default 
Constraint Set

Special
Constraint Set
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Standard (Default) Designregeln
Die Standardregeln sind generell unter dem CSet default einzutragen.

In der Spacing Domain können für alle Objekte gegenüber allen anderen Objekten Abstandsregeln 
vergeben werden. Dies kann auch auf jeder Lage einzeln erfolgen.

Alle Netze, die keine separate Zuweisung über ein weiteres CSet oder eine Direkteingabe haben, werden 
nach den Regeln des Default CSet kontrolliert bzw. geprüft.
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Spezielle Designregeln
Wenn Ihr Design komplexer wird, werden Sie bestimmten Netzen separate Regeln zuweisen müssen, 
die von den default Werten abweichen. Auch werden verschiedene Netze sich zueinander (Spacing) 
unterschiedlich verhalten müssen.
Dies erfordert die Anwendung der Extended Design Rules unter Berücksichtigung der nachfolgenden 
drei Schritte, sowohl für die Spacing, als auch die Physical Rules.

• Schritt 1: Generieren eines neuen Constraint Sets (CSet)
• Schritt 2: Generieren von Netzklassen, die die gleichen Constraints bekommen sollen
• Schritt 3: Zuweisung des Constraint Sets zu Netzen oder Netzklassen

Übung
Die wesentlichen Schritte werden auf den nächsten Seite in einer Übung durchgegangen, das auf dem 
bereits erstellten File netlist.brd basiert.
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Übung: Schritt 1 – Neues Rule Set (I)
Generieren eines neuen Rule Sets 
(CSet)
Alle Regeln werden möglichst in CSets
organisiert, um die Zuweisung dieser 
Regeln bei Mehrfachverwendung zu 
vereinfachen. Jede Regel kann natürlich 
auch für sich allein zugewiesen werden. 
1. Generieren eines neuen Spacing 

CSets: 
Bereich Spacing auswählen > RMB 
auf Design Name klicken > Create > 
Spacing CSet…

2. Geben Sie den Namen 3mm_Space
ein und klicken Sie OK.
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Übung: Schritt 1 – Neues Rule Set (II)
3. Wählen Sie Spacing Constraint Set > All Layers > All.
4. Ändern Sie alle Werte der DEFAULT Regel auf 0.3 mm.
5. Ändern Sie alle Werte der 3MM_SPACE Regel auf 3 mm.
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Übung: Schritt 2 – Netzklasse (I)
Generieren einer Netzklasse
1. Selektieren Sie die Netze AC1 

und AC2 und klicken 
RMB > Create > Net Class… > 

2. Tragen Sie den Namen 220V ein 
und klicken OK.   
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Übung: Schritt 2 – Netzklasse (II)
3. Jetzt sind AC1 und AC2 als Mitglieder zu Net Class 220V erstellt.
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Übung: Schritt 3 – Zuweisung
Zuweisung der einzelnen Rule Sets zu den Netzklassen
1. Wählen Sie Spacing > Net All Layers > Line.
2. Wählen Sie das Feld rechts neben dem Netzklassen Name 220V an. Ein Auswahlfenster öffnet sich.
3. Selektieren Sie 3MM_SPACE.
4. Jetzt ist die Netzklasse 220V mit dem Regelsatz 3MM_SPACE verknüpft.
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Physical und Same Net Rule Sets
Die Handhabung der Rule Sets im Physical Worksheet und im Same Net Spacing Worksheet ist 
analog den Schritten 1 bis 3 des Spacing Worksheet der vorigen Übung. 
Sie müssen nur vorher im Worksheet Selector des CM die jeweilige Kategorie auswählen.

Tipp
Die Rule Sets der 
Worksheets
• Physical
• Spacing
• Same Net Spacing
sind voneinander völlig 
unabhängig, und müssen 
daher separat erstellt und 
zugewiesen werden.
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Constraint Modes (I)
Die zu den im Constraint Manager definierten und zugewiesenen Regeln gehörigen Checks müssen 
noch aktiviert werden.

Das geht im Constraint Manager unter Analyze > Analysis Modes
oder im PCB Editor unter Setup > Constraint > Modes
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Constraint Modes (II)
Im Constraint Manager lassen sich eine Vielzahl von weiteren Checks konfigurieren, auf die in dieser 
Kurzanleitung jedoch nicht eingegangen werden kann.

Hinweise zu den verschiedenen Checks sind in den Analysis Modes zu finden.
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Constraint Manager Webinare
Weiterführende Informationen hält die FlowCAD Webinar Serie zu den verschiedenen Themen zum 
Constraint Manager für Sie bereit:

Effektiver Einsatz von Constraint Management (DE)

High Speed Regeln (DE)

Physikalische Regeln / Abstandsregeln (DE)

Regeln für die Fertigung (DFM) (DE)

https://youtu.be/h97rI3hBvnw
https://youtu.be/77U1cCTiLgQ
https://youtu.be/-VHry24f3Jo
https://youtu.be/bdVp6Z6NQ6Y
http://www.youtube.com/FlowCAD
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Bauteilplatzierung (Allgemein)
Nach erfolgtem Setup der Design Constraints werden in diesem Abschnitt die verschiedenen 
Möglichkeiten der Bauteilplatzierung vorgestellt und wiederum anhand unseres Beispiels als Übung 
durchgeführt.

Diese Informationen benötigt der PCB Editor für die Platzierung:
• Netzliste 
• Package Symbol (Footprint)
• Padstack
• Shape Definitionen (für spezielle Pad-Geometrien)

Footprints und Padstacks (inkl. Shapes) müssen dem PCB Editor über Bibliotheken zur Verfügung 
gestellt werden.
Die Pfade zu den Bibliotheken werden über PSMPATH und PADPATH definiert und sind im env-File 
gespeichert.

Ergänzende Elemente für die Platzierung sind:
• Floorplanning (kann u. a. durch die ROOM Property bereits im Schematic vorbereitet werden).
• Package Keepouts (verhindert ein Platzieren von Bauteilen auf gesperrten Bereichen). 

Hinzuzufügen durch: Setup > Areas > Package Keepout.
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Bauteilplatzierung (Typ)
Im Wesentlichen werden drei Arten der Platzierung unterschieden:
1. Manuelle Platzierung (Place > Manually): Hierbei werden die Bauteile aus der Liste der zu setzenden 

Bauteile ausgewählt und manuell gesetzt.
2. Quickplace (Place > Quickplace): Semiautomatische Platzieren von Bauteilgruppierungen 

entsprechend gewählter Kriterien.
3. Automatische Platzierung (Place > Autoplace): Automatisches Platzieren von Bauteilen. Hierbei sind 

zusätzliche Definitionen erforderlich, z. B. Platzierungsraster.

Nachfolgend werden nur die manuelle Platzierung und Quickplace vorgestellt.
Insbesondere bei der manuellen Platzierung ist die sinnvolle Einstellung des Platzierungsraster (Setup > 
Grids) notwendig.
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Place Manually…
Die manuelle Platzierung selbst starten wir wie folgt: 
Place > Manually oder

Es stehen insgesamt fünf Optionen zur Auswahl:
• Components by refdes

Auswahl der Bauteile nach REFDES, 
entsprechend  der geladenen Netzliste

• Components by net group
Platzierung entsprechend der Net Group 
Definition im Constraint Manager

• Package Symbols
Platzieren von Packages (Footprints) ohne 
elektrische Information hinsichtlich der Netzliste

• Mechanical Symbols
Platzieren von mechanischen Symbolen (z. B. 
zusätzliche Outline oder Befestigungsbohrungen)

• Format Symbols
z. B. Zeichnungsrahmen für Doku

Der Selections Filter stellt eine Vielzahl von praktischen Auswahlkriterien 
zur Verfügung. 
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Platzierungsvorlage
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Übung: Place Manually (I)
Im Folgenden werden der Ablauf und die Optionen der Platzierung am Beispiel des im vorigen Kapitels 
erzeugten Files constraints.brd erläutert. Als Vorlage soll die Darstellung der vorigen Seite dienen. Nach 
dem Laden der Netzliste (Import > Logic) ist zunächst nur die Information, welche Bauteile in dem Design 
verwendet werden, geladen worden. Erst mit Platzieren werden die Footprints in das Board File geladen.

1. Öffnen Sie das constraints.brd
2. Place > Manually…
3. Unter Advanced Settings Library selektieren
4. Wählen Sie als erstes Bauteil den Trafo T1
5. RMB > Rotate (Pin 1 und 5 nach links)

Alternativ Short-Key R entsprechend der 
Definition in Kapitel 2.

6. LMB, um T1 zu positionieren.
Platzieren Sie den Trafo in die linke obere Ecke 
des Boards. Beachten Sie das P in der aktuellen 
Placement-Liste nach erfolgter Platzierung.

7. Schließen Sie das Placement Fenster mit OK.
8. Platzieren Sie keine weiteren Bauteile.
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Filterparameter
Bevor Sie die Platzierung vervollständigen, wollen wir kurz auf die verschiedenen Auswahlkriterien des 
Selektionsfilters eingehen. Insbesondere bei größeren Boards sind diese Filterkriterien bei der manuellen 
Platzierung unverzichtbar und erhöhen die Effizienz der Arbeit enorm.
Das Selektionsfilter erlaubt die Definition von Platzierungsoptionen durch eine Limitierung der Bauteile, 
die anschließend zur weiteren Selektion zur Verfügung stehen.
Bitte testen Sie obige Optionen anhand des vorliegenden Testbeispiels, bevor Sie die Platzierung 
vervollständigen, da nach erfolgter Platzierung nicht alle Optionen mehr verfügbar sind.
Wählen Sie die Optionen, die Ihrer Vorgehensweise am besten entsprechen.

Match Mittels REFDES und Wildcard „*“ und anschließender TAB-Taste können 
z. B. nur Kondensatoren (C*)  zur Auswahl gebracht werden.

Property Selektion nach vordefinierten Properties und Values, einschließlich 
User Properties. 

Room Platzierung nach Room Property, sogenanntes Floorplanning.

Part # Platzierung nach Sachnummer, sofern vorhanden.

Net Platzierung aller Bauteile, die an ein bestimmtes Netz angeschlossen sind.

Schematic page number Nur für Design Entry HDL als Font-End-Tool.

Place by refdes Zusätzliche Selektion von Class Property und Pin-Anzahl möglich.
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Weitere Befehle (I)
Während oder auch nach der Platzierung werden natürlich weitere Funktionen benötigt, um ein Design zu 
realisieren bzw. zu modifizieren.

Nachfolgend die wichtigsten Funktionen, zu erreichen über Edit > … oder die aufgeführten Icons.

Move Bewegen von Elementen

Copy Kopieren von Elementen

Mirror  Bauteile von Top auf Bottom verschieben

Spin Drehen von Elementen

Delete Löschen von Elementen

Tipp
Bei allen Funktionen ist besonders auf den 
Find-Filter und die umfangreichen Optionen 
im Option Control-Panel zu achten.

Viele Funktionen stehen 
im Rechte Maustaste 
Menü zur Verfügung. 
Z.B. Rotate ist als 
Unterfunktion von Move
oder Place vorhanden. 
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Weitere Befehle (II)
Ratsnet OFF / ON Guidelines aus / ein (Display > Show / Blank Rats >…)

Assign Color Permanente Farbzuweisung auf beliebige Elemente

Highlight / Dehighlight Anwendung des Find-Filters und Option Panels auch über 
Display > Assign Color / Highlight / Dehighlight aufrufbar.

Setup > Design Parameters… Mirror und Angle erlauben eine Voreinstellung der unter 
Place > Manually > Design ausgeführten Platzierung hinsichtlich
TOP / BOTTOM und Drehung.

Ergänzende Elemente für die Platzierung:
• Floorplanning (kann u. a. durch die ROOM Property bereits in der Schematic vorbereitet werden)
 Setup > Outlines > Room Outline…

• Package Keepouts / Keepins / Height (Platzieren von Bauteilen in restriktiven Bereichen)
 Setup > Areas > Package Keepout / Keepin / Height
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Quickplace
Quickplace starten wir über Place > Quickplace…
Mit Quickplace steht ein sehr flexibles und universell 
einsetzbares Tool zur Verfügung, um die Platzierungsarbeit 
möglichst effektiv zu gestalten.
So können Sie durch einen Klick überprüfen, ob alle über die 
Netzliste zugewiesenen Footprints auch bibliotheksmäßig zur 
Verfügung stehen. Setzen Sie hierzu:
• Placement Filter auf Place all components
• Placement Position auf Around package keepin
Und jetzt Place
Unplaced Symbol count gibt dann die Auskunft, ob Bauteile 
nicht platziert werden konnten, weil die Bibliothek diese nicht 
enthielt oder der Bibliotheks-Pfad fehlte.
Welche Bauteile dies sind, ist über Place Manually zu prüfen.
Alle weiteren Optionen sind selbsterklärend, wobei bei einigen 
natürlich die Definition der entsprechenden Properties im 
Stromlaufplan erfolgt sein muss.

Tipp
Unplace ist nur möglich, solange Quickplace nicht über OK 
abgeschlossen wurde.
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Übung: Place Manually (II)
1. Wählen Sie Place > Manually…
2. Beachten Sie, dass T1 nun in der Liste nicht mehr aufgeführt ist.
3. Selektieren Sie jetzt ROOM in Selektion Filter und wählen als Room Gleichrichter.
4. Es werden C1, C2, D1 und L1 im Auswahlfenster gezeigt.
5. Selektieren Sie D1 und rotieren um 180 Grad.
6. Platzieren Sie über die Kommandozeile: Eingabe: x 30 45 und Enter.
7. Selektieren Sie die Kondensatoren und platzieren diese mit Pin 1 nach links (270 Grad) auf: 

45 45 und 45 35.
8. Selektieren Sie L1 und platzieren Sie die Drossel mit Pin 1 nach oben (270 Grad) auf: 37.5 40.
9. Selektieren Sie jetzt ROOM im Selection Filter und wählen Sie als Room U-Regler.

10. Es werden die restlichen Bauteile angezeigt. Selektieren Sie alle.
11. Platzieren Sie der Reihe nach auf: 45 25; 45 20; 45 15; 45 10 (90 Grad); 37.5 12.5 (90 Grad), 

RMB > Done.
12. Nochmals Place > Manually. Die Liste für Comp by Refdes ist leer, alle Bauteile sind platziert.
13. Schließen Sie das Placement Fenster mit OK.
14. Edit > Change und selektieren im Option Panel Text Block + 6, Find Filter auf nur Text.
15. Klicken Sie auf jeden REFDES oder ziehen ein Rechteck über eine Gruppe. REFDES haben nun 

eine Größe.
16. Edit > Move und setzen das Find Filter auf nur Text.
17. Verschieben Sie jeden REFDES laut Vorlage, unter zusätzlicher Verwendung des Rotate Befehls 

(z. B. RMB).
18. Speichern Sie Ihr Ergebnis als placed.brd ab.
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3D Canvas I
Über View > 3D oder        kommen Sie in den 3D Canvas. Mit dem 3D Canvas Filter kann dann selektiert 
werden, was im 3D Canvas dargestellt werden soll.
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3D Canvas II
Unter Setup > Preferences > Symbol Representation lässt sich einstellen, wie die Bauteile dargestellt 
werden.
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3D Canvas III
Wenn sich der PCB Editor im Placement Edit Application Mode 
befindet, lassen sich Bauteile über RMB > Move
im 3D Canvas bewegen.
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Routing
Das Routing ist das Verlegen der Kupferbahnen entsprechend der Netzliste. Es ist sowohl interaktiv als 
auch automatisch (bei entsprechender Lizenz) durchführbar. 
Beide Routing Typen sind sowohl über Icons als auch Pull-down-Menüs (Kommando) aufrufbar.

Add Connect (Route > Connect): Manuelles Routen der elektrischen Verbindungen
Slide (Route > Slide): Verschieben von existierenden Bahnen
Create Fanout (Route > Create Fanout): Hinzufügen von Fanout / Pin Escape vor dem Routen
Custom Smooth (Route > Custom Smooth): Optimieren der Leiterbahnführung
Edit Vertex (Edit > Vertex): Hinzufügen / Entfernen von Vektoren an 

existierenden Bahnen

Auto Route Param / Route (Route > PCB Router > Route Automatic):
Öffnen der Parameterform und Starten des PCB Routers im Hintergrund.
In dieser Anleitung wird nur auf das interaktive Routing eingegangen.

Add Connect

Slide
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Routing Grid
Das Etch Grid wird immer dann sofort angezeigt, 
sobald ein Route Kommando wie z. B. Route > 
Connect ausgeführt wird. Es ist das Fangraster, 
das beim interaktiven Routen mit der Maus 
benutzt wird.
Wählen Sie Setup > Grids und tragen Sie in 
All Etch die Werte wie dargestellt ein.
Die Grids On Box kontrolliert die Sichtbarkeit des 
Grid Rasters.
Wenn in All Etch Eintragungen gemacht werden, 
werden diese für alle Lagen übernommen. 
Wünschen Sie unterschiedliche Raster in 
einzelnen Lagen müssen Sie diese Werte auch 
einzeln eintragen.

Achtung
Bei unterschiedlichem Raster in den einzelnen 
Etch-Lagen ist ein Via nur im gemeinsamen 
vielfachen Raster aller Lagen möglich. 



109FlowCAD Confidential  │

Routing:
• Routing Start über: Route > Connect oder

− Das Verhalten des Routing wird über das Options-Panel eingestellt.
• Selektieren des Startpunktes mit LMB z. B. T1 Pin 9

• LMB um geplanten Pfad zu fixieren.
• LMB auf Endpunkt, um Routing abzuschließen.
• Neue Verbindung durch RMB > Next.
• Beenden des Connect Befehls durch RMB > Done.
• RMB > Oops macht den letzten Schritt rückgängig.
• RMB > Cancel beendet den Befehl, ohne Änderungen zu 

übernehmen.

Einfügen von Vias:
• RMB > Add Via oder Doppelklick
• Einstellung, welches Via verwendet wird und auf welche Lage 

gesprungen wird, erfolgt ebenfalls im Options Panel

Übung: Routing
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Routing Options 
Im Kapitel Design Rules wurden bereits einige Voreinstellungen 
bezüglich Leiterbahnbreite und Leiterbahnabstand behandelt. Wenn wir 
jetzt mit dem Verlegen von Leiterbahnen beginnen und den Online DRC 
aktiviert haben, wird man bereits vom Tool aktiv unterstützt. Die 
voreingestellte Leiterbahnbreite wird z. B. sofort als Parameter richtig 
eingestellt. Wir können diese Breite allerdings im Rahmen der Vorgaben 
noch verändern. Verlassen wir diesen Bereich, so erhalten wir sofort eine 
DRC-Meldung vom System und können entsprechend reagieren.
Wurde nur der Befehl Route > Connect gestartet, ohne ein Pin oder 
Ratsnet (Guideline) zu selektieren, zeigt das Option Panel die default 
Werte:
Via: No available Via (da kein Netz selektiert)
Net: Null Net (da kein Netz selektiert)
Line width: 0.3 (default Wert, wenn kein Netz selektiert)

Sobald ein Netz selektiert wird (Pin angeklickt), werden die für das Netz 
gültigen Werte angezeigt.
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Alternate Mode / Working Layer Mode 
Beim Alternate Mode werden zwei Lagen direkt im Options-Panel selektiert und es kann beim Routing 
zwischen ihnen gewechselt werden.
Der Working Layer Mode ist besonders für das interaktive Arbeiten mit hochlagigen Multilayern 
interessant. Wenn dieser Mode eingestellt ist können Sie beliebige Lagen definieren, die Sie beim 
interaktiven Routen vorrangig benutzen wollen. Sind mehrere Lagen freigegeben, kommt beim Setzen 
eines Vias ein Fenster hoch, in dem die gewünschte Lage selektiert werden kann. Plane-Lagen können, 
wenn gewünscht, komplett ausgeblendet werden. 

Alternate
Mode

Working
Layer Mode
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Net und Line Optionen

Line width:
Sind dem selektierten Netz im 
Constraint Manager konkrete 
Werte, so werden diese 
verwendet, ansonsten werden die 
default-Werte aus dem default
Constraint Set benutzt. Tipp

Bitte beachten Sie, dass sich die 
Einstellungen der Parameter Line 
Lock und Miter gegenseitig 
beeinflussen, d. h. auch die 
Kreisbögen können z. B. durch 
Miter Parameter entsprechend 
beeinflusst werden.

Winkel:
45 / 90: Fixer Winkel
Off: Beliebiger Winkel

Eckenabschrägung:
Min = keine Längenbegrenzung
Fixed = linker eingetragener Wert 
wird verwendet (1 x width)

Line lock:
Line: Geroutet werden 
gerade Linien
Arc: Geroutet wird 
in Kreisbögen
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Schieben, Glätten der vorhandenen Leitungen

Bubble:
Die Einstellungen bestimmt, 
was mit vorhandenen Leitungen 
geschieht.
Off: Es wird über andere Linien 
darüber geroutet.
Hug Only: Linie schmiegt sich 
immer existierenden Linien an.
Hug prefered: Linie schmiegt 
sich bevorzugt existierenden 
Linien an.
Shove prefered: Andere Linien 
werden verschoben.

Shove vias:
Off: Vias werden nicht 
verschoben.
Minimal: Vias werden 
geringfügig verschoben.
Full: Vias werden 
mitgeschoben.

Smooth:
Off: Vorhandene Linien werden 
während des Routens nicht 
geglättet.
Minimal: Minimal Glättung 
vorhandener Linien.
Full: Bessere Glättung
Super: Maximal Glättung
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Editieren vorhandener Leitungen (I)
Im PCB Editor stehen umfangreiche Möglichkeiten zur Verfügung, bestehende 
Kupferbahnen zu editieren, d. h. deren Verlauf nachträglich zu verändern.
Route > Slide: Verschieben von Leiterbahnen entsprechend den verwendeten

Optionen.
Vorher Nachher

Vorher

Nachher

Edit > Vertex: Erzeugen von neuen Eckpunkten oder Verschiebung bestehender.

Edit > 
Change:

Veränderung der Lagenzuordnung 
oder Breite bestehender Leiter-
bahnsegmente; bei Lagen-
änderung werden automatisch 
Vias platziert.
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Editieren vorhandener Leitungen (II)
Delete: Löschen von Leiterbahnen und Vias. Ripup Etch:

Cut Option (RMB > Cut): Dient der Definition konkreter Bereiche innerhalb 
eines Segments.

Edit > Delete Route > Slide Edit > Change (width)

Benutzen Sie Ripup etch und Clines, 
wenn Sie alle Segmente und Vias zwischen 
Pins auf mehreren Lagen löschen wollen.

Cline Segs:
Löscht einzelne 
Segmente eines Netzes.
Clines:
Löscht alle Elemente 
eines Netzes außer Vias.
Vias:
Löscht Vias.
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Glossing
Glossing dienen beide der Verbesserung der Leiterbahnführung hinsichtlich der Fertigung.
Zum Beispiel können, durch interaktive Arbeit entstandene, überflüssige Beulen (Bubbles), Treppchen 
(Jogs) und Antennen (Dangling lines) automatisch beseitigt werden.
Darüber hinaus bietet OrCAD eine Vielzahl von Glossing Optionen, die hier nicht betrachtet werden 
können.

Route > Gloss > Line Smoothing…



117FlowCAD Confidential  │

Übung: Routing
1. Laden Sie das placed.brd der vorherigen Übung und nutzen Sie die erworbenen Kenntnisse, um 

entsprechend der Vorlage Ihr eigenes Design zu vervollständigen.
Rot ist Top
Grün ist Bottom

2. Platzieren Sie den Text 
Power_Supply auf der Top-Lage.

3. Speichern Sie das fertig geroutete
Board unter routed.brd.

Netznamen können wahlweise eingeblendet werden unter Setup > Design 
Parameters > Display > Display Net Names.
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Kupferflächen (Shapes)
Kupferflächen, im Folgenden Shapes genannt, spielen zur Spannungsversorgung und Abschirmung eine 
große Rolle.
Der PCB Editor beherrscht sowohl statische, als auch dynamische Shapes. Dynamische Shapes werden 
ständig online neu berechnet, z. B. wenn in diese hineingeroutet wird.

Tipp
Heutzutage werden im Allgemeinen 
dynamische Shapes verwendet.
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Smooth entspricht der 
Gerberdatenausgabe.

Fast berechnet die Shapes 
schneller, optisch ist das 
Ergebnis kaum vom Smooth 
zu unterscheiden. 

Disabled: Shape-
Aussparungen werden nicht 
berechnet. Über Update to
Smooth lassen sich alle 
Shapes aktualisieren.

Global Dynamic Parameters: Shape Fill
Unter Setup > Global Dynamic Params… lassen sich die allgemeinen Parameter für alle neuen Shapes 
einstellen. Bei Bedarf können die Einstellungen für jedes Shape einzeln angepasst werden.

Tipp
Gegitterte Shapes, wie sie z. B. häufig in flexiblen Leiterplatten 
verwendet werden, können unter mit dem Xhatch style
konfiguriert werden.

Dynamic fill:
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Global Dynamic Parameters: Void Controls
Die hier gemachten Einstellungen beeinflussen 
die Ausführung der Shapes.

Das Artwork Format sollte auf RS274X, dem 
Industrie Standard, gesetzt werden. Auf das 
Artwork Format wird später bei der Erzeugung der 
Fertigungsdaten genauer eingegangen.

Create pin voids:
Individual: Pins bekommen einzelne Aussparung.
In-line: Aussparung wird zusammengefasst.

Acute angle trim control:
Beeinflusst Ausgabe der Ecken.

Tipp
Generell gilt, dass allen Shapes auf einem Board immer das gleiche Format zugewiesen ist. Somit ist 
dieser Punkt von der individuellen Parametrisierung einer Shape ausgeschlossen.
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Global Dynamic Parameters: Clearances
In den Clearences wird definiert, mit welchem Abstand die verschiedenen Padarten ausgespart werden 
sollen.
Default ist DRC, d. h. es werden die Werte verwendet, die im Constraint Manager definiert wurde.

Tipp
Vermeiden Sie Oversize values. Die richtigen 
Abstandswerte sollten von vorneherein im 
Constraint Manager eingestellt sein.
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Global Dyn. Param.: Thermal Relief Connects
Hier wird definiert, wie die Thermalanschlüsse ausgeführt werden. Es können separate Definitionen für 
Thru Pins, SMD Pins und Vias getroffen.

Diese Einstellung beeinflusst die 
Thermalanschlüsse.

Shapes, die als Xhatch gefüllt sind, können die angegebene Xhatch-Line-Width auch als 
Thermalanschlussbreite verwenden.
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Layer Dynamic Parameters
Die Shape Parameter lassen sich über Shape > Layer Dynamic Params auch für die einzelnen Lagen 
individuell einstellen.
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Shapes hinzufügen
Über das Shape Menü lassen sich Shapes 
hinzufügen:

Sie haben die Wahl 
zwischen zwei Shape 
Typen, Dynamic und 
Static Shape.

Nach der Definition der 
Außenkontur erfolgt bei der 
Dynamischen Shape ein 
automatisches Freisparen 
der betreffenden Elemente. 
Auch nach jeder weiteren 
Änderung werden die 
Elemente automatisch 
ausgespart.

Tipp
Bitte überprüfen Sie vor Beginn der Shape 
Generierung folgende Punkte:
• Global Dynamic Parameter
• Aktive Lage
• Gewählten Netznamen

Shape Buttons:

Shape Options:

Spannungs-
versorgungs-Netze, 
die die Voltage
Property haben
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Übung: Shape Generierung
1.Laden Sie das Board routed.brd.
2.Setzen Sie das Gerberformat unter Shape > Global 

Dynamics Parameters… > Void controls auf RS274X.
3.Wählen Sie Shape > Rectangle.
4.Schalten Sie Ground-Lage sichtbar (Visibility).
5.Setzen Sie Class und Subclass auf Etch / GND.
6.Setzen Sie den Fill Type auf Dynamic.
7.Weisen Sie der Shape den Netznamen GND zu. Nutzen 

Sie hierzu den Browser      im Option Panel.
8.Klicken Sie RMB, um die lokalen Shape Parameter zu 

definieren. Nur bei positiver Shape sinnvoll.
9.Ziehen Sie ein Rechteck (2 x Klick mit LMB) über den 

rechten Teil des Boards entsprechend der Vorlage.
10.Beenden Sie mit RMB und Done.
11. Beachten Sie, dass die Shapekontur von der Route 

Keepin (gelbe Linie) begrenzt wird, und diese auch 
gleichzeitig eine neue Shapekontur definiert.

12.Wiederholen Sie den selben Ablauf für die Top-Lage.
13.Wählen Sie Edit > Move mit Filter auf Shape und 

verschieben Sie die Shape. 
Beachten Sie, dass die einmal erzeugte Shapekontur im 
Hintergrund immer erhalten bleibt.
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Editieren einer Shape
Im Shape Menü stehen eine Vielzahl von 
Möglichkeiten zum Editieren der Shapes 
zur Verfügung.

Tipp
Achten Sie beim Editieren einer Shape immer 
darauf, dass Sie die richtige Lage im Option 
Fenster eingestellt haben.
Sie können einer Shape jederzeit, wenn 
erforderlich, ein anderes Netz zuweisen.
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Design Rule Check und Reports

https://www.flowcad.com/de/solutions.htm
https://www.flowcad.com/de/download.htm
https://www.flowcad.com/de/training.htm
https://www.flowcad.com/de/events.htm
https://www.flowcad.com/de/news.htm
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Design Rule Check
Verletzungen der Designregeln werden grundsätzlich online durch die 
DRC Symbole (Schmetterlinge) im Layout angezeigt (siehe Bild rechts).
Genauere Informationen über die DRCs erhält man über Display > 
Element (Find Filter auf DRC errors setzen).

Alle DRC Verletzungen werden im DRC Browser aufgelistet, 
der über Tools > DRC Browser geöffnet wird. 

Durch Doppelklicken auf die Koordinaten, springt die Arbeitsfläche an 
die Stelle, an der sich der DRC befindet.

https://www.flowcad.com/de/white-paper-CM.htm
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Display Status
Über das Pop-up-Menü Display 
Status erhalten Sie einen 
schnellen Überblick über den 
Designstatus.
Beim Klicken auf die farbigen 
Knöpfe erhalten Sie detaillierte 
Informationen. Bei einigen 
Optionen sind auch Links 
vorhanden, die die 
Arbeitsfläche beim Anklicken 
an die entsprechende Stelle 
springen lassen.

Sind alle Bauteile 
platziert?

Sind alle Netze 
geroutet?

Sind alle Shapes 
aktuell und 
fehlerfrei?

Ist der DRC Check 
aktuell und wie 
viele Fehler 
sind vorhanden?
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Reports
Eine weitere Möglichkeit alle 
möglichen Informationen aus dem 
Design zu extrahieren, bieten die 
Reports.
Diese können über Tools > 
Reports erzeugt werden.

Ein sehr nützlicher Report ist etwa 
der Component Report. Zum 
Auswählen klicken Sie doppelt auf 
den gewünschten Report in der 
Available reports Liste oben.
Mit Generate Reports wird der 
Report geschrieben.
Über New / Edit lassen sich auch 
eigene Reports konfigurieren. 
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Ausgabe der Fertigungsdaten

https://www.flowcad.com/de/solutions.htm
https://www.flowcad.com/de/download.htm
https://www.flowcad.com/de/training.htm
https://www.flowcad.com/de/events.htm
https://www.flowcad.com/de/news.htm
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Fertigungsdaten – IPC-2581
Neben den klassischen Fertigungsdaten –
Gerber- und Drill-Daten – verfügt der PCB Editor 
auch über die Möglichkeit IPC-2581 und ODB++ 
Daten auszugeben.
Sowohl in den IPC-2581 als auch in den ODB++ 
Containern sind alle für die 
Leiterplattenherstellung und Bestückung 
notwendigen Daten enthalten.

IPC-2581-Daten lassen sich über File > Export > 
IPC 2581 ausgeben.
Mit dem Functional Mode lässt sich einstellen, ob 
Daten für die Leiterplattenherstellung, die 
Bestückung oder andere Arbeitsschritte 
geschrieben werden sollen.

https://www.flowcad.com/de/white-paper-ipc2581.htm
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Fertigungsausgabe – Gerberdaten
Die klassische Ausgabe der Fertigungsdaten, 
bestehend aus Gerber- (Artwork) und Bohrdaten 
(NC-Drill), erfolgt in zwei Teilen.
Bei der Gerberausgabe werden die für die 
verschiedenen Gerberlagen benötigten 
Informationen aus der Datenbasis (xyz.brd) 
zusammengesetzt.
So setzten sich z. B. die Gerberdaten für die Lage 
Top aus Etch / Top, Pin / Top und Via Class / Top 
zusammen.
Die hier beschriebenen Filmdefinitionen werden 
auch im IPC-2581 und ODB++ verwendet.

Top.art
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Übung: Gerberdaten (I)

Bitte stellen Sie diese Werte ein:
Devicetype (Photoplotter Modell):
Gerber RS274X – Extended Gerber
Film size limits (verfügbare Plotfläche):
Größe des Ausgabefilms: 24 x 16 mm
Format (Integer / Dezimal places):
Vorkomma- / Nachkommastellen: 2,5
Output Units (Einheit der Ausgabe):
Millimeters

Tipp
Nutzen Sie möglichst Extended Gerber (RS274X), 
da dieses Format bereits die Blenden enthält.
Verwenden Sie gleiche Units in Board und 
Ausgabe.
Nicht zu niedrige Auflösung (Nachkommastellen).

Über Manufacture > Artwork gelangt man in die Oberfläche zur Gerberdatenausgabe. Im Tab General 
Parameter werden die Grundeinstellungen der Ausgabe durchgeführt.
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Artwork Film Options

Filename: Namen des Films
PDF Sequence: Nummer des Filme in der pdf-Ausgabe
Rotation: Filmdrehung, üblicherweise 0
Offset: x / y-Verschiebung
Undefined line width: Photoplotbreite für Linien mit 
undefinierter Breite (geben Sie hier immer einen Wert an, um 
zu vermeiden, dass Strukturen nicht ausgegeben werden).
Shape bounding box: Bei negative planes wird die 
Kupferfläche um den eingetragenen Wert zurückgezogen.
Plot mode: Negative, nur bei negativer Plane üblich
Film mirrored: Normal nicht benutzt (LP-Hersteller)
Full contact...: Unterdrückung von Thermalanschlüssen auf 
Kupferflächen
Suppress …: Unterdrückung nicht angeschlossener Pads
Vector based …: Laserplotterverhalten ähnlich dem 
Vektorplotter bei Blitzblenden
Draw holes only: Shapes in Bohrungsgröße werden erzeugt, 
sobald nur Pins und / oder Vias im Film zugewiesen sind.

Für jeden Filmrecord werden die eingestellten Optionen separat abgespeichert.
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Übung: Gerberdaten (II)

• Um einen neuen Film zu definieren, stellen Sie 
unter Display > Color Visibility die 
gewünschten Lagen sichtbar und alle anderen 
aus.

• Wenn Sie jetzt im Artwork Control Form RMB > 
Add wählen, werden die sichtbaren Lagen zu 
einem Film zusammengefast.

Im Film Control Panel müssen alle Filmrecords definiert werden, die zur Ausgabe benötigt werden. Per 
Default erscheinen hier bereits alle, die unter Setup > Subclasses… > Etch definiert wurden. 
Zusätzliche Filmrecords wie Soldermask_Top, Asembly_Top usw. müssen selbst definiert werden.
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Übung: Bohrdaten
In das Menu zur Erzeugung des Bohrfiles gelangen Sie über: 
Manufacture > NC > NC Drill

Auto tool select: Erfordert ein extra File nc_tools.txt für 
automatischen Werkzeugwechsel der Bohrmaschine.
Separate files for ...: Getrennte Files für durchkontaktierte und 
nicht durchkontaktierte Bohrungen.
Repeat Codes: Sollte eingeschaltet bleiben.
Optimize drill …: Wegoptimierung beim Bohren.
Format und Output units sollten den Einstellungen in den 
Gerberdaten gleichen!

Weitere Einstellungen sind unter Parameters zu finden.

Drill startet die Erzeugung der Bohrdaten.
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Dokumentation: NC-Drill – Legende
• Um dem Layout eine Drill Legende zuzufügen, benutzen Sie Manufacture > NC > Drill Legend.

• Über Library lassen sich Template Files für verschiedene Einheiten auswählen.

• Bei Blind und Burried Vias werden automatisch mehrere Drillcharts und Drill-files erzeugt. 

Titel der Legende und 
Lagenkombination

Tipp
Wenn der Find Filter auf Group gesetzt wird, lässt sich die 
Legende insgesamt verschieben.
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Board Vorlagen

https://www.flowcad.com/de/solutions.htm
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Board Vorlagen
In diesem Abschnitt wird ein kurzer Einblick in die Erstellung eines mechanischen Board-Symbols oder 
einer Board Vorlage geben. Board Vorlagen sind immer dann sinnvoll, wenn im Layoutprozess häufiger 
gleiche Strukturen (Outline, Technologie oder vorplatzierte Bauteile) verwendet werden. 

Ein mechanisches Board-Symbol beinhaltet üblicherweise folgende Elemente:
• Boardoutline, Keepin / Keepout (Route und Package) Via Keepout, Bemaßung
• Befestigungsbohrungen  

Ein Masterboard kann folgende Elemente beinhalten:
• Board Symbol (.bsm) 
• Zeichnungsrahmen (.osm)
• Vorplatzierte Bauteile, z. B. Steckverbinder (.psm)
• Technologievorgaben (Abstandsregeln, Leiterbahnbreiten, etc.)
• Lagenaufbau
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Übung: Board Symbol
Um ein Board Symbol zu generieren gehen Sie 
wie folgt vor:
• File > New > Mechanical Symbol
• Tragen Sie Outline in das Drawing Name 

Feld ein.
• OK
• Im Create a New Design Dialog, der 

automatisch hochkommt, können Einheit und 
Größe des Zeichenblattes festgelegt werden.

• OK
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Übung: Board Symbol
• Alle weiteren Einstellungen lassen sich unter 

Setup > Design Parameters… > Design
vornehmen.

• Insbesondere sollte die Genauigkeit der 
Datenbasis groß genug gewählt werden.
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Übung: Board Symbol
• Setup > Grids
• Im Non Etch Bereich tragen Sie 2.5 für x 

und y ein.
• OK um Form zu schließen.
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Übung: Board Outline generieren
Wir nehmen an, dass der Nullpunkt (0,0) der Outline die linke untere Befestigungsbohrung ist.
1. Add > Line vom Hauptmenü.
2. Setzen der aktiven Class und Subclass auf Board Geometry / Design_Outline.
3. In der Kommandozeile des Editors tragen Sie folgende Zeilen ein, und schließen jede mit Enter ab.  

x -30 10
x -10 10
x -10 -10
ix 80
iy 70
ix -100
iy -50

4. RMB > Done. Die Outline sollte 
nebenstehender Darstellung 
entsprechen. 

Tipp
Absolutkoordinaten: x value value
Relativkoordinaten:  ix oder iy value
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Der zweite Schritt ist das Hinzufügen von Befestigungsbohrungen.
1. Layout > Pin vom Hauptmenü oder den Add Pin Icon

Klick Browse Button            im Option Fenster im Padstack Feld.
2. Selektieren von Hole120

Der Editor zeigt eine Message Using Hole120.pad, d. h. es war möglich, 
das Pad in der Library zu lokalisieren.

3. In der Kommandozeile tragen Sie 
nacheinander folgende Daten ein, 
und bestätigen Sie jeweils mit Enter.
x 0 0
x 60 0
x 60 50

4. RMB > Done.

Übung: Befestigungsbohrungen
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Übung: Bemaßung (I)
Der dritte Schritt wäre die Bemaßung. Der OrCAD PCB Editor verfügt über eine dynamische Bemaßung, 
d. h. eine Veränderung der Kontur führt automatisch zur Anpassung der bestehenden Bemaßung. 
Die Bemaßung kann sowohl im PCB als auch bereits im Symbol durchgeführt werden. Die Bedienung ist 
in beiden Fällen identisch.

Im PCB Editor geschieht dies 
durch Manufacturing > 
Dimension Environment im 
Symbol Editor durch Dimension > 
Dimension Environment.
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Übung: Bemaßung (II)
Die für die Bemaßung erforderlichen Kommandos sind über das rechten Maustaste 
RMB zu erreichen.
Nachfolgend wollen wir die Bemaßung am Beispiel der Outline 
(mech. Symbol) erläutern.
Über Parameters lässt sich die Bemaßung anpassen.

Tipp
Bitte achten Sie beim Arbeiten mit den 
Bemaßungen darauf, das Sie immer im 
Dimension Environment bleiben. Ansonsten 
lassen sich die Dimensions nicht bearbeiten.
Dies erkennen Sie am besten an der Status 
Zeile.
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Übung: Bemaßung (III)
Nach erfolgter Parametereinstellung starten Sie mit:
1. RMB > Linear Dimension
2. Das System fordert Sie auf einen Punkt oder ein 

Element zur Bemaßung anzugeben.
3. Selektieren Sie die obere LP-Kante (100) und 

platzieren Sie den Text. 
4. Selektieren Sie die rechte LP-Kante (70) und 

platzieren Sie den Text.
5. Vervollständigen Sie entsprechend der Vorlage.
6. Für eine Punkt zu Punkt Vermaßung (untere 

Bohrungen -60) müssen diese Koordinaten exakt 
selektiert werden (Filter beachten), die 
Segmenterfassung erfolgt automatisch. 
Sie können hierbei auch die Snap-Funktion 
einsetzen.

7. Bei nicht reiner orthogonaler Vermaßung muss 
mit einem zusätzlichen Klick dem Tool die 
gewünschte horizontale oder vertikale Richtung 
zur Vermaßung mitgeteilt werden (linke untere 
Ecke mit den Maßen 10 und 20).
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Übung: Bemaßung (IV)
8. Um das dynamische Verhalten der gesamten Vermassung zu testen, ändern Sie z. B. die Position der 

unteren rechten Befestigungsbohrung.
9. Wählen Sie Edit > Move oder das Icon         und bewegen Sie genannte Bohrung.
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Komplettes Boardsymbol
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Masterboard
Ein Masterboard ist eine Board Vorlage, die neben der Außenkontur zusätzlichen Einstellungen enthält, 
die zum Arbeiten benötigt werden, wie: 
Lagenaufbau, Designregeln, eventuell auch vorplatzierte Bauteile.
Diese Methode spart erheblich Zeit und erhöht die Qualität, da eine Prüfung bestimmter Parameter nur 
einmal vorgenommen werden muss und anschließend immer wieder verwendet werden kann. 

(.osm)

(.psm)
Cross section 
(stackup)

Design rules

PCB Editor (.brd)

(.bsm)
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Übung: Masterboard Setup
Auf den folgenden Seiten werden die wichtigsten Schritte aufgeführt, um ein Masterboard zu erstellen. Im 
Übrigen gelten diese Schritte ebenso für die Erstellung eines x-beliebigen Boards.
1. File > New vom Hauptmenü.
2. Tragen Sie master in das Drawing Name Feld ein.
3. Wählen Sie den Drawing Type Board.
4. OK.

5. Setup > Design Parameters… > Design
6. Ändern Sie die Werte entsprechend der Drawing 

Parameter Dialog Box (links).
7. OK.

Tipp
Die Drawing Extents sollten so groß gewählt sein, dass auch Zusatzelemente wie ein Zeichnungsrahmen Platz 
haben. Accuracy sollte groß genug gewählt werden, um Shapes und feine Leiterbahnen richtig aufzulösen. 
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Übung: Masterboard Lagenaufbau

Dieses Menü erlaubt Ihnen weitere elektrische Lagen (Routinglagen) hinzuzufügen oder auch wieder zu 
entfernen. RMB > Add Layer / Remove Layer.
Der Subclass Name von TOP und BOTTOM ist Default und nicht veränderbar, alle zusätzlichen Lagen 
können individuell einen beliebigen Namen (aber unique) erhalten. Die hier gewählten Namen 
erscheinen auch im Option Visibility Fenster.
Über Type kann zwischen Conductor (Routing Lage), Dielectric und Plane (Power Lage) 
gewählt werden.

Die Einstellungen des Lagenaufbaus sind über Setup > Subclasses > Etch oder         zu erreichen. 

Tipp
Ein Löschen von zusätzlichen Lagen 
ist nur dann möglich, wenn diese 
Lagen keine Daten mehr enthalten.
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Übung: Masterboard, Boardsymbol

1. Place > Manually vom Hauptmenü, es erscheint die 
Placement Box (rechts).

2. Selektieren Sie unter Advanced Setting Tab beide 
Optionen Database und Library.

3. In der Placement List expandieren Sie Mechanical Symbols 
und selektieren Sie Outline (selbst definiertes Symbol).

4. In der Kommandozeile tragen Sie x 0 0 ein und Enter.
5. RMB > Done. Das mechanische Symbol ist platziert.
6. File > Save As. Es wird ein master.brd File gespeichert.
7. PCB Editor nicht schließen.

Wie bereits mehrfach erwähnt, ist es sinnvoll bei wiederkehrenden Designs ein vordefiniertes 
Boardsymbol (Mechanical Symbol) in ein Masterboard aufzunehmen, um den Designprozess effektiver 
und sicherer zu gestalten.
In das noch offene Masterboard master.brd laden wir das Boardsymbol wie folgt:

Tipp
Sie können an dieser Stelle ebenso Bauteile vorplatzieren 
(Package Symbol), Format Symbole hinzufügen als auch 
weitere Voreinstellungen bezüglich Grid, Farben und auch 
Designregeln vornehmen. 
Auf Designregeln gehen wir ab Seite 78 ein. 
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Abschlussbemerkungen
Wie bereits eingangs erwähnt kann und soll dieser Schnellstart kein Training ersetzen.

Es sollte hier lediglich ein grober Einblick in den Funktionsumfang dieses Leiterplatten-Entwicklungstools 
gegeben werden, der es ermöglicht, erste selbstständige Schritte durchzuführen und das Tool zu 
beurteilen.

Unabhängig von dieser Einführung wird grundsätzlich ein Training empfohlen, um die volle 
Leistungsfähigkeit ausschöpfen zu können und das Tool effektiv in der täglichen Arbeit einzusetzen. 

Diese Trainings werden von Cadence bzw. FlowCAD regelmäßig angeboten. Näheres hierzu finden Sie 
auf den Websites von Cadence und FlowCAD:

www.cadence.com

www.FlowCAD.de/Training

http://www.cadence.com/
https://www.flowcad.com/de/training.htm
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Anhang
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Systemvoraussetzung (Vollversion 22.1)
Operating Systems Windows 11 Professional and Enterprise

Windows 10 (64-bit) Professional and Enterprise, including Dark Theme mode;
Windows Server 2016 (All Service Packs)
Windows Server 2019

Hardware Intel Core i7 4.30 GHz or AMD Ryzen 7 4.30 GHz with at least 4 cores
Note: Faster processors are preferred.
16 GB RAM
50 GB free disk space (SSD drive is recommended)
1920 x 1200 display resolution with true color (at least 32 bit color)
A dedicated graphics card supporting OpenGL, minimum 2 GB (with additional 
support for DX11 for 3D Canvas)
Dual monitors (for physical design)
Broadband Internet connection for some service
Ethernet port / card (for network communications and security HostID)
Three-button Microsoft-compatible mouse
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Please do not hesitate to contact us.
Für weitere Fragen und Informationen stehen wir gerne zur Verfügung.

FlowCAD Deutschland
Mozartstr. 2
85622 Feldkirchen bei München
T +49 89 45637-770
info@FlowCAD.de

FlowCAD Schweiz
Hintermättlistr. 1
5506 Mägenwil
T +41 56 485 91 91
info@FlowCAD.ch

FlowCAD Polska
ul. Sąsiedzka 2A
80-298 Gdańsk
T +48 58 727 90 90
info@FlowCAD.pl

Contact us / Kontakt zu FlowCAD 
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Follow Us

» FlowCAD.com » youtube.com/
FlowCAD

» FlowCAD.com/
newsletter

» linkedin.com/
FlowCAD

» facebook.com/
FlowCAD

» twitter.com/
FlowCAD

» instagram.com/
FlowCAD

» xing.com/
FlowCAD

Don’t forget to subscribe, share and like! 

http://www.twitter.com/FlowCAD
http://www.youtube.com/FlowCAD
http://www.facebook.com/FlowCAD
https://www.xing.com/companies/flowcadeda-softwarevertriebsgmbh
https://www.flowcad.com/
https://news.flowcad.ch/?p=subscribe&id=3
https://www.linkedin.com/company/flowcad/
https://www.instagram.com/flowcad.eda/
https://www.flowcad.com/de/index.htm
http://www.youtube.com/FlowCAD
https://news.flowcad.ch/?p=subscribe&id=3
https://www.linkedin.com/company/flowcad/
http://www.facebook.com/FlowCAD
http://www.twitter.com/FlowCAD
https://www.instagram.com/flowcad.eda/
https://www.xing.com/companies/flowcadeda-softwarevertriebsgmbh
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