PSpice Tips and Tricks
# Table of Contents

1. **Introduction** .................................................................................................................... 3
2. **PSpice Templates** .......................................................................................................... 3
    2.1 Design Entry Capture ...................................................................................................... 3
    2.2 Design Entry HDL ......................................................................................................... 4
3. **Probe Customization** ..................................................................................................... 4
4. **Cursor** .................................................................................................................................. 5
5. **Export Data** .................................................................................................................. 6
    5.1 Export Cursor Values ..................................................................................................... 6
    5.2 Export Trace Values ...................................................................................................... 6
6. **Copy Simulation Results** ............................................................................................... 7
7. **Reuse Display Settings** ................................................................................................... 8
8. **Append Waveforms** ....................................................................................................... 9
9. **Performance Analysis** ................................................................................................... 9
10. **Optimizer** .................................................................................................................... 10
    10.1 Introduction .................................................................................................................. 10
    10.2 Example ....................................................................................................................... 10
    10.2.1 Create a New Project .............................................................................................. 10
    10.2.2 Starting Simulation .................................................................................................. 11
    10.2.3 Create Measurement .............................................................................................. 11
    10.2.4 Start the Optimizer ................................................................................................. 13
    10.2.5 Setup the Optimizer .............................................................................................. 14
    10.2.6 Results ..................................................................................................................... 15
11. **Monte Carlo Analysis** ................................................................................................ 15
    11.1 Introduction .................................................................................................................. 15
    11.2 Example ....................................................................................................................... 15
    11.2.1 Add Tolerance Value .............................................................................................. 16
    11.2.2 Start Simulation ....................................................................................................... 17
    11.2.3 Setup the Monte Carlo Analysis ............................................................................... 17
    11.2.4 Results ..................................................................................................................... 18
1 Introduction

This application note describes some helpful features of PSpice for the daily work and demonstrates on simple examples how PSpice Advanced Analysis can be used.

In the first part you find some practical information how to use PSpice. The second part shows how simple the use of PSpice Advanced Analysis (AA) is. Note, PSpice AA is a separate product and requires a separate license. In the Demo-Mode you can run the examples as described in this application note with certain limitation.

Don’t hesitate to contact us if you want to know more about PSpice or PSpice AA.

2 PSpice Templates

When creating a new PSpice project, there are a lot of Templates to choose of. The Templates are included in the installation. The examples are completely finished and ready to use for simulation.

These examples are:
- A good starting point for designer
- Good for learning
- Quick initial setup

2.1 Design Entry Capture

![Design Entry Capture Screenshot]
2.2 Design Entry HDL

When working with the Design Entry HDL you find the examples in following directory:
<InstallDirectory>\SPB_17.2\tools\pspice\concept_samples\design_examples

3 Probe Customization

In the Probe Window you can change the color, line width and pattern of each trace. This helps to improve the readability of the results in the Probe Window.

Right-Click on a Trace > Trace Property

In Tools > Options > Color Settings you can predefine a certain color order for the traces.
The dockable cursor window shows you the values of the two cursors. Even the measurement values are displayed.

To activate the cursor, go to Trace > Cursor > Display. To switch on and off the cursor window, go to View > Cursor Window.

You can place the cursors with the right and left mouse button. Each cursor has his own mouse button.
5 Export Data

5.1 Export Cursor Values

When selecting the cursor window, perform a right mouse button click and choose the command **Dump to CSV File**. All the data will be exported to a .csv-file which can be read for example with Microsoft Excel.

![Export Cursor Values](image1)

5.2 Export Trace Values

Right-Click on a trace and select **Copy to Clipboard** or click on the trace name and use keyboard shortcut **ctrl+c**. In the image V(C1:1) is selected.

You can paste the trace values for example in Microsoft Excel or in a texteditor.

![Export Trace Values](image2)
You can also use the **File > Export** option to export the traces you need in the format you want.

### 6 Copy Simulation Results

You can copy the simulation curves as a picture and paste them in other programs, for example to Microsoft Word.

- **Click Window > Copy to Clipboard…**
- **Choose the color filter as you prefer.**
- **Paste the picture in your desired program.**

---

![Copy Simulation Results](image-url)
7 Reuse Display Settings

Your actual probe window settings, as displayed curves, axis settings, etc. can be stored. This function allows you to define several display profiles. Every saved session can be restored. Use for this purpose the command Window > Display Control.

With Save you store your actual display session and with restore you can load a stored session.

**Note**

The Display Settings are stored in the Project Folder.
8 Append Waveforms

You can add stored waveforms to your actual probe window. Stored waveforms have always the .DAT file format. For this purpose, use the command File > Append Waveform (.DAT).

9 Performance Analysis

Probe is very useful as a waveform viewer to check the output of a simulation. In addition, it has a Performance Analysis feature, which allows it to be much more versatile and useful for evaluating the behaviour of a design.

It works only in a multi-section simulation; it means simulations that perform a variable sweep such as a parametric or Monte Carlo Analysis.

Start the Performance Analysis with Trace > Performance Analysis.

A Wizard guides you through the different steps.
10 Optimizer

10.1 Introduction

The Optimizer analyzes analog circuits and systems, fine-tuning designs faster than trial-and-error bench testing. It helps find the best component values to meet performance goals and constraints. Designer can use the Optimizer to improve design performance, update designs to meet new specifications, optimize behavioural models for top-down design and model generation, and tune a circuit to match known results in the form of measurements or curves. You can define several goals to optimize. The requirements could be simple, for example an output voltage. But you can also define complex requirements as a cut-off frequency of a lowpass-filter.

10.2 Example

On a simple example we demonstrate how easy it is to use the optimizer. The goal is to change the center frequency from 160Hz to 500Hz with the optimizer.

10.2.1 Create a New Project

In Capture, chose New > Project and enter a project name.
Choose the ResonantFilters.opj template.

In this example we’re working with the Series LC Resonant Band Stop Filter. The Demo-Version has limitations. So, if you’re working in demo-mode, please delete all components except the Series LC Resonant Band Stop Filter Circuit. After starting the simulation, you can delete the empty plots in the probe window.

10.2.2 Starting Simulation

You can directly start an AC-Simulation, the simulation profile is already defined.

![AC simulation graph]

10.2.3 Create Measurement

To measure the center frequency of a band stop filter, we can use cursor or create our own measurement function. We need this measurement afterwards for the Optimizer. So, we’ll create a new measurement.

Trace > Measurements

You get a list with all existing measurement. With New you can create your own measurement.
Enter a name for the new measurement, in our case **Center_Frequency_Bandstop**. Click **OK**.

To measure the frequency at the minimum value of a trace, the command is:

```plaintext
Center_Frequency_Bandstop(1 = x1
{    
1)Search forward min 1;
}
```

Click **OK** to close the Edit New Measurement window.

**Note**

If you would like to know more about the syntax of creating measurements, please read in the PSpice User Guide.
Afterwards you can use your new created measurement:

**Trace > Evaluate Measurement…**

- Choose on the right-hand side the measurement. In the field **Trace Expression** appears the chosen function.
- Choose on the left-hand side the curve on which you want to apply the measurement function.

The measured frequency is about 160Hz.

### 10.2.4 Start the Optimizer

We want to change the center frequency from 159Hz to 500Hz. This can be done with the Optimizer.
Start the Optimizer with PSpice > Advanced Analysis > Optimizer.

10.2.5 Setup the Optimizer

1. Define the goal measurement, in our case it’s the center frequency. Right-Click > Import Measurement > Center Frequency Bandstop

2. Define the value which we want to achieve with the Optimizer. We define 490Hz as minimum and 510Hz as maximum value.

3. Choose the component which can be modified with the Optimizer. In our case we choose C4. Right-Click > Import Parameter > C4 > OK
4. Define the range in which the component value can vary.
   We limit the value range from 1uF to 100uF.
5. Define the Optimizer engine.
   We choose the random engine.
6. Start the optimization process.

10.2.6 Results
The Optimizer simulates the entire circuit and changes the value of the component C4 in the
defined range. In the Error Graph we can select a Run. For the selected run, the component
value and the result are shown.

The best result was achieved at run #12. The component value for the capacitance is 1uF and
the calculated center frequency is 500Hz. So, our goal center frequency is achieved.

11 Monte Carlo Analysis

11.1 Introduction
Monte Carlo predicts the behaviour of a circuit statistically when part values are varied within
their tolerance range. Monte Carlo also calculates yield, which can be used for mass
manufacturing predictions. Designers use Monte Carlo for calculating yield based on your
specifications, calculating statistical data, displaying results in a probability density histogram,
and displaying results in a cumulative distribution graph.

11.2 Example
On the same circuit as used in the Optimizer Example, we want to demonstrate how quick and
easy you can set up a Monte Carlo Analysis. In this example we analyze, how the center-
frequency of this series LC Resonant Band Stop Filter can vary.
11.2.1 Add Tolerance Value

Click on **Assign Tolerances** to add tolerances to be used in Advanced Analysis.

- $C_4 \rightarrow 20\%$
- $L_4 \rightarrow 20\%$
- $R_2 \rightarrow 1\%$

**Note**

In Monte Carlo in Advanced Analysis you can distinguish positive tolerance and negative tolerance.
11.2.2 Start Simulation

Starting the Monte Carlo Analysis:

11.2.3 Setup the Monte Carlo Analysis

We first have to select the measurements on which we want to make a Monte Carlo analysis. So, we choose the Center-Frequency Measurement.
On Edit > Profile Setting we set the number of runs to 100 so that we get a significant result.

Results

Monte Carlo analysis varies the value of each component between the defined tolerance boarders. The values are calculated randomly.

The results are displayed in a graph. You can see that the center frequency varies between 420 and 610Hz.

With the cursor you can define your yield-border.

For example, you specify your filter with a precision of +/-10% and you want to know how many circuits are in the range. So, you allow a center frequency between 450Hz and 550Hz.

You can define a cursor on each frequency and the yield is automatically calculated.

The result is, that 75% of the 100 runs are between your specified tolerances!
For each run the component values are stored on a separate section of the log file (View > log file > Monte Carlo). For example, these are the values for the second Monte Carlo Run:

*********** MonteCarlo Run 2 ***********

Param : R2.VALUE (R_R2.VALUE) = 495.01251258888516
Param : L4.VALUE (L_L4.VALUE) = 102.54341257972960m
Param : C4.VALUE (C_C4.VALUE) = 877.32169560838645n

Specs : Center_Frequency_Bandstop(V(Vout4)) = 530

Note

You can run the Monte Carlo Analysis for this circuit also in the Demo-Mode. The limits for the Monte-Carlo Analysis in the Demo Mode are:

- Only one measurement specification.
- A maximum of three devices with tolerance are supported.
- Maximum of 20 Monte Carlo runs are supported.