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Introduction

• This documentation is created for first time users of OrCAD Capture Software. It is neither a training 

handbook nor a complete user manual.

• Because of the compactness of this documentation, it is not possible to take up all available 

commands and their options. Please refer to the extensive documentation within the installation, 

which is available as HTML as well as PDF.

• Based on a simple schematic, we will describe most important steps of design flow. With minimum 

effort of training it will enable first time users to manage their first tasks by them self. 

• After some preliminary information related to the software, the instructions including the circuit 

template will start on page 7.

• All commands and functions used in this tutorial are available and licensed with this trail version.
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OrCAD PCB Design Flow

• As you can see, OrCAD PCB Designer Flow consists mainly of two parts. 

− These are the schematic capture module Capture and the layout module OrCAD PCB Editor. 

• Both modules are supplemented by additional sub packages who represent in each combination an 

ideal tool, enabling the user to complete all tasks with maximized efficiency.
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Capture Design Flow

The graphic shows a typical flow, creating a schematic, following by PCB layout design. Numbers 1 to 10 

represent the individual steps in the design process, where we will focus on next. Process starts with 

project creation and will end with handover to PCB layout.
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Schematic Template

Here you can see circuit to be implemented in this quick start:
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Schematic Template – Parts List

The circuit to be implemented in this quick start contains following parts:

REFERENCE VALUE PART_NUMBER PCB Footprint

C1 220u FC-CAP-0057 capp_taj_e

C2 220u FC-CAP-0057 capp_taj_e

C3 100n FC-CAP-1019 cap_th_s_rm15x17_5x7x13_5

C4 100n FC-CAP-1019 cap_th_s_rm15x17_5x7x13_5

L1 100n FC-IND-0003 ind_0805

R1 1.2k FC-RES-0356 res_th_a_rm10_16x2_54

R2 22k FC-RES-0001 res_3269w

T1 EI30 FC-TF-0001 ei30_1579

U1 B40C800 FC-REC-0001 rec_b40_tht

U2 LM317 FC-IC-0001 sot223
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Start of Capture

When starting Capture, 

Capture Session Frame 

window will open.

Start via:

Start > 

Cadence PCB 17.4 2019 > 

Capture CIS 17.4
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Start Page

During start, interactive start page gets loaded to open existing projects or to create new projects. 

Furthermore, you receive additional information such as application notes, training data, etc.
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New Project Setup
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Lab: New Project Creation

File > New > Project… creates a new project, 

where a design will be stored in.

Since we are not planning to simulate, 

keep Enable project simulation inactive.

In top field under Name, please enter the name of 

your project, i.e. Power_Supply.

For project type choose PC Board Wizard, 

because we also like to create a PCB design with 

this project.

In bottom field Location, please choose the folder 

in which new project will get stored.

It is recommended to create a folder for each 

individual project.
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Project Power_supply

A new project with name 

Power_supply and a design with 

same name power_supply.dsn is 

created. 

First page of your design with name 

PAGE1 was opened at same time. 

Please note folder structure in 

project manager on left side 

of the picture.

Folder structure is virtual, meaning it 

does exist only inside project 

manager. PAGE1 under schematic

can only be found within 

power_supply.dsn file.

In contrast, libraries listed below are 

physical files under displayed paths 

located.
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Setup – Grid Display

At menu item Options > Preferences, please set 

Grid Display to 1/1. This ensures that symbol 

pins are on grid and can be easily connected.

To avoid placing parts outside grid, please 

activate Snap to Grid:
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Setup – Drawing Frames

Appearance of drawing frames can be configured under Options > Schematic Page Properties. In Grid 

References you can define subdivision of frame in sections and its width (Capture adjusts frame width to 

grid settings).

Tip

Settings can also be saved to a template that will 

affect all new pages and projects. 

For this purpose, settings can be made under 

Options > Design Template.

More details can be found in chapter Settings and 

Templates starting page 82.
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Part Placement
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Part Search via Database (I)

• CIS Explorer can be started via pull-down menu with Place > Database Part or via keyboard 

shortcut Z.

• Different database tables can be found in upper left corner.
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Part Search via Database (II)

• Please open misc_view and select folder Crystal. A table entry appears in lower window. If this is 

selected, complete preview of part is opened (arrangement of windows can be designed individually). 

Entry under Datasheet is a link to data sheet of manufacturer. Double-clicking green highlighted entry 

causes part to hang on mouse and can be placed on schematic page. 

• With keyboard shortcut Z, CIS Explorer comes to foreground again.
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Part Search via Database (III)

• Please open cap_view and select X7R. Several entries appear in lower window. 

• Double-clicking on a column header sorts the list according to this value. 

• If you select capacitor with 4.7pF in 0603 package, two data sets with manufacturer information linked 

to the part appear in manufacturer table. 

• Graphical representation in schematic can be selected in column Schematic Part.
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Part Search via Database (IV)

• Upper left window has two tabs. Query allows to search for parts using their values. For example, 

4.7pF capacitor can also be found by entering values shown below. Property and Compare fields are 

equipped with drop-down menus that allow easy selection of search options.
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Part Status

• If you go to cap_view category in CIS Explorer, you will see that listed parts are colored differently:

− Standard parts are green

− Locked parts are red

− Special parts are black
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Part Placement without Database
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Part Placement from Library (I)

Besides the possibility to select parts from a database that provides metadata, OrCAD Capture also 

offers to select and place parts directly from a library (.olb).

• Advantage

− No library database is needed.

• Disadvantage

− All part information must be manually defined as properties (effort, error-prone).

− Variant management is not possible.
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Part Placement from Library (II)

You can use one of three methods 

to place new parts:

• Place > Part... via  

pull-down menu

• P (keyboard)

• Place Icon

on right side

Tip

One of the schematic pages 

must be active to make icon 

panel visible (right margin).
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Part Placement from Library (III)

• Placement command opens menu as shown.

• In Libraries you can select one or more libraries in which 

your part can be searched. 

• Enter part label in Part. This already behaves as a filter, 

but without usage of wildcards “*”.

• Search results and related library are visible in Part List.

• Search for Part allows a search including wildcards. 

• Add Library        allows to add libraries to search path. 

• Packaging indicates if a part consists out of multiple gates 

or slots like a resistor pack or an IC with multiple gates. 

• With a double click in part list you get back into schematic 

and can place the part with LMB (left mouse button).
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Library Assignments

• Choose the necessary libraries for the project 

assigned.

• Left window contains all libraries installed 

during software installation. Additional libraries 

can be added at any time. Libraries assigned 

to project are listed in right window.

• Select the desired library and press Add 

button for assignment.

• How to define new parts that cannot be found 

in any existing libraries is described in chapter 

Libraries starting page 62.
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Adding / Edit Text



28FlowCAD Confidential  │

Text – Adding and Edit

Pure text notes can be added to schematic with

• Place > Text

• T (keyboard)

• Place Text Icon 

Font and size can be modified during text 

placement with command Change.
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Connections
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Connections (I) – Auto Wire

Two Points 

− Two selected pins are automatically connected 

to each other.

Multiple Points

− Multiple selected pins are automatically 

connected to each other.

Connect to Bus

− Multiple selected lines are connected to a bus.
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Connections (II) – Auto Wire

To use function Two Points, you only need to select two pins or nets. 

Connection get automatically wired. 
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Connections (III) – Manually

Connection can also be done manually:

• Place > Wire

• W (keyboard)

• Place Wire Icon  

For manual connection, user must click 

for each direction change with left 

mouse button to fix a vertex of 

connection. 

Otherwise this is identical to Auto Wire 

command.
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Connections (IV) – Method

Wiring is performed by a click on open end, 

marked by a red square on a pin. This 

marker disappears after connection is done.

Red dot signalizes a pin which is available 

for a connection. Another click on this 

object completes connection. Red dot and 

square will disappear. A double click will 

complete the task and release all objects.

Cross sections of nets represents a 

connection only if a dot or a junction gets 

placed or a t-junction is used as a interim 

step. 

By simply selecting a connection and 

pressing Del key, an existing connection 

can be deleted again.

Tip

Ctrl key allows selection of multiple objects 

at same time.
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Connections (V) – Net Names

Net name assignment

To connect parts on one schematic page, Place > Wire command 

is used to perform wiring.

Another option is usage of Net Aliases.

Place > Net Alias...

Place Net Alias Icon

A net name is assigned to nets and used to connect two parts. 

Net with name plus is used as an example here.

Tip

To connect nets via net names across multiple sheets or even across designs, Offpage Connectors or 

Port Connectors are used. More details can be found in documentation.
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Property Editing



36FlowCAD Confidential  │

Edit Properties (I)

After placement and wiring, schematic should look something like this:

It is possible that labeling

of parts (RefDes value)

is not matching schematic

template on page 7.

To correct this, 

values and REFDES

of parts can be edited. 

This makes also sense 

for a bill of materials

generated later in the 

process. 

RefDes

Value
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Edit Properties (II)

Edit REFDES and value

Property window can be opened by

Selection (LMB) and RMB > Edit Properties …

or by

Double click

on desired property.

Via Display Format different settings related to visibility in 

schematic are possible.

Tip

It is possible to open property editor for multiple symbols, 

all symbols on one sheet or even for entire design.

• Ctrl + LMB Click or Ctrl + A followed by

RMB > Properties...

• Select Page or Design (.dsn) in Project Manager, 

Edit Object Properties from pull-down menu.
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Packaging – Annotation

Packaging and annotation of parts

On previous page, we have assigned reference 

designators manually. During editing, Capture does not 

verify if duplicated reference designators exist (2 x U1, 

or 3 x R5). Verification happens during handover to 

OrCAD PCB.

Via Tools > Annotate… you have the option to 

complete this task automatically and guaranteed 

without any duplicate reference designators. For this 

function many options are available (to make command 

available, you must select .dsn file in project folder, 

otherwise Annotate command is not visible).
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Complete Schematic

After schematic is adjusted and parts, text got aligned, completed schematic should look similar to 

schematic on this page.

Note

At this point we would like to mention 

that because of used libraries 

assignment of footprints (DIP14, SO14, 

SMD1206, etc.) is not done so far.

This is a subject for later when we 

import data into layout module.

Just a upfront information:

Footprint assignment has to be done in 

schematic. A missing footprint entry will 

cause an error message during data 

synchronization. If name is not finalized, 

it is possible to use a dummy text string 

as a placeholder.

Footprints can be predefined in library or 

via a property editor later assigned.
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Design Rule Check

DRC is able to identify one pin nets, nets 

without input or output. Pre condition is a 

correct defined library. 

Please select .dsn file in project folder, 

otherwise command Design Rule Check

will not be available.
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Bill of Material (BOM)
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Design Variants
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Variants – Overview

• Following steps are necessary to create design variants:

− Dividing design into meaningful groups, for example, according to function blocks

− Creating subgroups that reflect assembly variants of blocks

− Creating BOM variants of entire projects (these are actual variants used by assembly house)

− Adding subgroups to BOM variants to create desired assembly

• These steps are explained in detail on following pages.
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Variants – Example Design

• Capture Quick Start contains a variant sample design:

− ~\Capture_CIS_Schnellstart_17_4\Solutions\VARIANT_DESIGN.DSN

− Groups, subgroups and variants are already preconfigured in this example.

− Creation of variants is described in this chapter.
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Variants – Groups

• With Part Manager you can manage parts in your design, carry out database updates or generate 

variants.

• Select .dsn file and click RMB > Part Manager or use menu Tools > Part Manager > Open.

• To describe variants, you need to divide the design into groups.

• It makes sense to store all parts of a function group in one group of variant description. Function 

groups that do not have any assembly variants remain in common group.

• Select Groups > RMB > New Group. Create a group named Clock. Repeat this process and 

generate group PCIE.
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Variants – Subgroups

• Next step is to define subgroups that contain different assembly variants of groups. 

• Select the group Clock > RMB > New Subgroup. 

• Enter Alternate. 

• Repeat this process, and enter HalfMounted and then FullMounted.
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Variants – Assign Parts to Groups

• Open Clock page and select all parts. 

• RMB > Add Part to Group, select the group Clock > Add. 

• Repeat this action with second page and move all capacitors (not connector) into group PCIE.
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Variants – Unmounted Parts

• Go to Part Manager and select a subgroup HalfMounted. 

• Select some parts and set them as not present with RMB > Set Part as not present. 

• All unmounted parts are marked with a red cross.

• Repeat this action in another subgroup.
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Variants – Alternative Placement

• Go to Alternate subgroup and select a part, preferably a resistor or capacitor RMB > Link Database 

Part. 

• CIS Explorer opens, and an alternative part can be selected. Make sure that parts have identical 

symbols and footprints. This can be ensured, for example, by a query search in which footprint is 

specified.

• CIS Explorer supports you in your search. Properties with different contents are highlighted in red.

• Link Database Part also works if you select several identical parts in Part Manager. All parts with 

alternative placement are marked with a green tick.
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Variants – Define BOM

• Select BOM Variants > RMB > New BOM 

Variants and enter name BOM1. Repeat for 

BOM2 and BOM3.

• Drag one subgroup per group into BOM. 

Finally, common group must be added to 

BOM, as it contains PCIE connector, that has 

not been assigned to any group.

• Variant BOM is shown in lower right corner.
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Variants – Schematic

• Close Part Manager, go to a schematic page 

with variant description and select View > 

Variant View Mode. Select one of the 

variants. Unmounted parts are displayed in 

grey with lettering DNI, parts with an 

alternative placement are displayed in green. 

• You can set colors via Options > 

Preferences.
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Variants – Report

• You can use Variant Report to check variant 

definitions or compare them with core design. 

Open Part Manager and select Report > 

Variant Report. Make settings as shown in the 

picture. Select one of the variants > OK. 

• Report is created and displayed. You get a 

direct comparison of core design and variant.
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Variants – Generate BOM

• BOM variants can be generated as shown on page 41 via Report > CIS Bill of Material > Standard. 

• Use an existing template and select one of variants below.

• You will find Variants Not Stuffed Qty 0 Displayed via list of variants. If you check this box, all 

unstuffed parts with number 0 in parts list are also displayed.

• Click OK to start parts list output. Variant BOM is displayed.
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Constraint Manager
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Constraint Manager in Capture

• This chapter in Capture Quick Start gives a brief Constraint Manager overview.

• You can find more detailed information in PCB Editor Quick Start starting on page 73.
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Constraint Manager in Capture

• To start Constraint Manager from Capture, please 

use command PCB > Constraint Manager or 

icon        .

• Confirm query with Migrate constraints from 

schematic design.
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Assign Voltages to Power Nets

• In next step, after first start of Constraint 

Manager, you can assign Voltages to Power Nets.
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Constraint Manager in Capture

• From a schematic point of view only definition of electrical constraints makes sense.

• Many Constraints require data from layout. This data is available after a back annotation from layout.
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Design Sync
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Generate Layout (I)

Via PCB > New Layout logic information can be 

transferred to a new PCB.

• PCB Layout Folder: Directory in which design 

sync information is written

• Input Board File: A base or board template

• Board: Newly generated board file
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Generate Layout (II)

• An existing PCB can be updated via PCB > Design Sync.

• Changes are displayed in form of an ECO list.
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Libraries



63FlowCAD Confidential  │

Missing Parts

In this chapter we describe how to search parts in web portals via function Search Providers. This 

function can be used to create new parts which are not part of OrCAD provided libraries.
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Part Search (I)

• If required parts are not available in assigned 

libraries, you have the option to search and 

download parts from Ultra Librarian and 

SamacSys web portal. 

• Portals provide datasheets, schematic 

symbols, footprints and step models.

• Select Place > Search Providers to start 

web search.

• To use web portals, a free of charge Cadence 

and Ultra Librarian account is required. 

• Please click on New user or forgot 

password? Click here to create free of charge 

accounts.
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Part Search (II)

• Search Providers user interface provides a Google like search.
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Part Search (III)

If required parts are not available in existing libraries, they can be downloaded from web portals.

Datasheet     Schematic Symbol     Footprint     Step Model available

During placement, parts will automatically be downloaded

with command RMB > Place Part and saved in home folder:

~/Site/Library/downloaded_parts
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Part Creation

New parts can also be created with OrCAD Capture provided capabilities.

Procedure will be demonstrated using LM317 as an example. This part is not available in original 

connected libraries.

• Counter.olb

• Discrete.olb

• OPAMP.olb

Completed part can be found in 

• Quickstart.olb
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New Library (I)

You can create new parts in a new library or

open an existing library and add new parts.

Both actions happens via

• File > New > Library

or

• File > Open > Library
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New Library (II)

New library can be saved in project manager

RMB > Save As... at new chosen path.

Afterwards this library can be assigned to your 

existing project.
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New Part Creation (I)

Via Design > New Part...

or

RMB > New Part

you can start creation of a new part in 

active library.
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New Part Creation (II)

Please enter displayed values into the form.

New Part Name:

Part Reference Prefix:

PCB Footprint:

Part Aliases:

Same symbol, same function, but different package

Parts per package:

i.e. 4 gates in 74LS00

Homogeneous:

Multiple identical circuits, i.e. 74LS00

Heterogenous:

i.e. relay with coil and switch

Part Numbering:

U?A, U?B ... oder U?1, U?2 ...

Click OK.
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Commands in Capture

Commands for part editing are available in Capture user interface. You can find them in panel right 

margin or in Place pull-down menu.

Hovering over icons shows 

functions as text.

On next pages we will explain 

most important functions.
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Adding Pins (I)

Place pins by:

• Place > Pin...

or

• Place Pin Icon
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Adding Pins (II)

Place Pin panel appears during pin 

property definition.

After clicking OK, pin is on the curser and ready 

for placement.

Tip

Using pin type Power allows visible and invisible 

pins.
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Adding Pins (III)

Individual pins get placed. Additional pins can be placed 

via previous menu or via copy / 

paste (Ctrl C, Ctrl V).

Placement of Pins is always 

adjusted to dashed line.

Package und pin properties can 

be modified with property sheet 

shown right. 



76FlowCAD Confidential  │

Symbol Graphics

Completion of symbols

Symbol outline gets assigned finally. Commands are:

• Place > Rectangle

• Place > Polyline

etc.

You can also use icons on right side of Part Editor window.

Tip

Dashed line is a frame to show real occupied area of symbol on 

schematic. This frame is invisible in schematic.

Rectangle can be selected and stretched or compressed over corners. 

Dashed frame is always at least as large as real symbol body. Only 

during symbol body expansion, rectangle will be adjusted automatically.
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Completed Symbol

Completed symbol LM317

Please do not 

forget to save!

Tip

Additional text or graphics 

for this part can be added 

via Place > Text and

Place > Line commands.
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Library Management

Now you can save library1.olb as 

Power_supply.olb. Voltage regulator LM317 is now 

stored in library Power_supply.olb.

If you need more parts, you can create them as well 

in this library.

You can assign this library to design projects as 

described on page 26.

All used parts of this quick start are available in 

library Quickstart.olb.
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Edit Database
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Edit Database (I)

• An SQLite editor is required to edit database entries. 

• You can download here, for example: https://sqlitebrowser.org/dl/

https://sqlitebrowser.org/dl/
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Edit Database (II)

• Desired part table must be opened for editing.

• Commands such as Copy / Paste and New Line are available there.
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Settings and Templates
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Design Template – Title Block

You can define pre settings for new projects and 

new pages in an existing project under Options > 

Design Template. 

In tab Title Block you are able to define text 

modules of title block.
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Design Template – Page Size

Size of schematic sheet can be defined 

at tab Page Size.

Attention

Settings under Pin-to-Pin Spacing must match 

pin-to-pin spacing used in library. This prevent 

later off grid connection problems.



85FlowCAD Confidential  │

Design Template – Grid Reference

Grid Reference defines width of 

drawing frame as well as count of 

horizontal and vertical segments.

Width

Separation

Count
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Appendix
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System Requirements (Full Version 17.4)

Operating Systems Windows 10 (64-bit) Professional, Windows 2012 Server (All Service Packs); 

Windows Server 2012 R2; Windows 2016 Server

Hardware Intel® Core™ i7 4.30 GHz or AMD Ryzen™ 7 4.30 GHz with at least 4 cores

16 GB RAM

50 GB free disk space (SSD drive is recommended)

1920 x 1200 display resolution with true color (at least 32 bit color)

A dedicated graphics card supporting OpenGL, minimum 2 GB (with additional 

support for DX11 for 3D Canvas)

Dual monitors (for physical design)

Broadband Internet connection for some services
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Properties of Full Version

In General

• Grid imperial or metric

• Easy to create or edit libraries

• Forward-backward annotation

• Cross-probing between design entry (Capture) and layout (PCB Editor)

Schematic Editor Capture

• Maximum workspace up to 11.430 x 11.430 mm

• Multiple designs as part of one project

• Hierarchical structures with automated synchronization

• Automated reference designator assignment

• Electrical Design Rules Check (configurable)

• Configurable automated drawing border and title block

• Export of different netlist formats

• TCL interface
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Usability Concept

• OrCAD Capture is menu driven.

• Menus are context sensitive. This means that panels or commands and resulting pop-up windows or 

pull-down menus get automatically adjusted to fit for selected objects.

• All commands or entries can get executed via following options:

• Pull-down menus

• Icons

• Short keys

• Pop-up windows

• There is no traditional command line. TCL script can be executed via command window.
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Files in OrCAD (Capture)

Most important files used by OrCAD Capture:

.OPJ Project 

.DSN Design

.DBK Backup

.OLB Symbol Library

.UPD Property Update File

.DRC Design Rules Check

.BOM Bill of Materials

.EXP Property Export File

.MNL Layout Netlist

.SWP Layout Backannotation

.VHD / .VHO VHDL Source 

.EDF / .EDN EDIF Netlist or Backannotation

.XRF Cross – Reference

.NET Other Netlist

Note

• Only design file *.dsn is necessary for sharing or external editing of designs. All design data is 
included in this file.

• Project-File *.opj is meaningful, but not necessary. It contains pre-settings of project as well as used 
libraries, output files, folder settings, etc.
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Please do not hesitate to contact us.

Für weitere Fragen und Informationen stehen wir gerne zur Verfügung.

FlowCAD Deutschland

Mozartstr. 2

85622 Feldkirchen bei München

T +49 89 45637-770

info@FlowCAD.de

FlowCAD Schweiz

Hintermättlistr. 1

5506 Mägenwil

T +41 56 485 91 91

info@FlowCAD.ch

FlowCAD Polska

ul. Sąsiedzka 2A

80-298 Gdańsk

T +48 58 727 90 90

info@FlowCAD.pl

Contact us / Kontakt zu FlowCAD 
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Follow Us

Don’t forget to subscribe, share and like! 

twitter.com/

FlowCAD

On FlowCAD’s 

Twitter we provide 

press releases, 

news articles, films 

and images as well 

as reports from 

events.

youtube.com/

FlowCAD

On our YouTube 

channel you can 

find 100+ tutorials 

to learn more about 

electronic circuits. 

Our playlists also 

offer product news 

and webinars.

facebook.com/

FlowCAD

Join our Facebook 

page. You will find 

selected news, 

events, success 

stories and 

insights.

FlowCAD.com/

newsletter

The FlowCAD 

newsletter for PCB 

designers appears 

about every two 

months. It is free 

of cost and will be 

sent by e-mail.

http://www.twitter.com/FlowCAD
http://www.youtube.com/FlowCAD
http://www.facebook.com/FlowCAD
https://news.flowcad.ch/?p=subscribe&id=3
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